Why my sketchup crash while opening

Not much to go on.

Are you trying to open an existing file?

Display driver, a misbehaving extension or a very large or faulty model file.

I am trying to run existing and new files but sketchup is not working on both. Even I tried after formatting my PC.

Would you mind elaborating about misbehaving extension?

Have you installed any extensions (plugins)?

nop there is not installed any extension

i have working on a project and suddenely crashed i have reinstalled but it doesn’t work, even i have formated my laptop.

How large is the project?
What were you doing when it Crashed?
Did it actually Crash or just show Not Responding as it does in your screen shot?
Have you tried updating your Graphic Card Drivers from the manufacturers website?
Have you tried opening an empty model?
Have you tried holding down shift while opening?
So many possible questions so little information.

the project is 37mb file

i was modeling wardrobe and suddenly not responding appears ,i again tried to open it but not opened ,just show not responding only.

yes i have tried updating graphic card but its doesn’t work

Not responding is not crashing, it means it is working and if left long enough should finish what it is doing.
If you upload your model someone will have a look at it and see if it can be cleaned up for you.
You would need to upload to dropbox or similar and put a link in a reply here.

finally it work when i disable my graphic driver.

Thanks all of you for your support.