Why is this floor not a solid component?

This is a 4" thick concrete floor in plan, in a SU Pro 2021 model, with an irregular profile.

It was created by pushpull from a clean, flat face, and Solid Inspector says “No Errors - Everything is shiny”.

At first the face wasn’t quite flat after trying to collapse three separately drawn 3D floors into one, but I used the Eneroth Flatten to Plane extension to make the top edges and partial face flat, then drew one line to create a complete single face after I deleted that last line.

And SU had no trouble pushpulling the face.

But SU doesn’t think it is a solid component.

Any ideas why not, and how it can be made so, and report a volume?

[Because it’s a uniform thickness, and the face shows an area in Entity Info, it isn’t difficult to calculate the volume of concrete needed (1/3 x the area in sq ft).]

But why isn’t it solid? Given the method by which it was created, I’d have thought it was bound to make a solid, but it doesn’t. Whenever I’ve previously had a problem making a solid, where a series of small edits over time have created extra or overlapping edges, recreating it from a flat surface with pushpull has always fixed it.

Basement floors.skp (87.4 KB)

PS. I also used CleanUp 3 to Repair edges before PushPull.

PPS. Saved back to v2017, Solid Inspector reports 12 Short Edges. Here are some of them.

By zooming in very close, on one corner, I finally see where two of the ‘short edges’ are - highlighted here in close-up.


And fixing those and others by moving the 4" tall pushpull lines so as SU eliminates duplicate edges and removes the short ones, eventually gets it a SU solid as well as for Solid Inspector 2.

Why CleanUp didn’t repair the short edges, I’m not quite sure.

But at least a have an explanation, though it doesn’t explain why SI2 in SU 2121 thinks it’s a clean solid, but in 2017 it doesn’t.

Basement floors SU2017.skp (88.7 KB)

Got no clue at the moment. Even copying the bottom face and push-pulling doesn’t report as a solid.

It’s weird.

If I explode the group and delete geometry so that only a face and perimeter geometry is left cleanup reports that there are nested groups and highlights them as some of the edges.

I agree. Did that too, from top and from bottom, on two different computers.

See updated post above for the fix I finally found.

OK - I too found some of them but not all. I think CleanUp doesn’t react because they aren’t coplanar.

When I’ve previously had straight edges that were more obviously split into two or more joined edges, CleanUp3 ‘Repair Edges’ seems to have consolidated them into a single line. But not in this one!

Perhaps because the ‘short edges’ weren’t exactly straight in line with the long edges - not collinear, rather than not coplanar? I did notice that when I tried to delete an extra 4" edge joining two short edges, the face disappeared, which suggests that they were not, indeed, part of a straight line, but had a slight bend there.

John, I think the problems arise from a tiny “bow tie bug” at one of the corners:

I copied the face out of the component, zoomed in very close and saw that little triangle sticking into the face. It creates a strange hollow there during pushpull. I erased that triangle, retraced the adjacent longer edge to regenerate the face. Then it pushpulls just fine and both SketchUp and SI2 report it as solid.

That was certainly one of the problems - I found it when I was chasing down the short edges. It did indeed make a kind of triangular tube inside the perimeter.

But there were other simple ‘short edges’ too - I only found the last one after thinking I’d fixed them all including that ‘bow tie’, and it STILL wasn’t solid.

Thanks to all for looking, and wondering as I did what had gone wrong, as well as confirming that there was a problem, and finding parts of the solution.

MORAL, perhaps.

If you do lots of edits with the line tool, when you have approximately the result you want, delete everything and start again, modelling cleanly!

Good work John!! It’s an interesting thread, pointing out once again, the importance of tightening up at that small scale. It’s a little frustrating that one can’t zoom in the required amount before it distorts to see the ultra small. SU and Solid Inspector both reporting it as solid. It looks like I need to add a few tools to my 2021 after reading this thread.

I’m late to the party but i also found the issues. I used the “Dave Method” to help, of course.

Is this related to the problem I’ve had where SU will create a face even if it’s not coplanar but “close enough”? Now that I’m aware, I’m much more fastidious about how I model and checking my faces if I create them in an unconventional way. But it has always bothered me that I couldn’t completely trust what I was seeing. Perhaps I still don’t get it, but I’d rather SU not complete the face if it’s not right. This just leads to compound errors.

If you are still unsure if a face is properly flat, you could fix it with the Eneroth Flatten to Plane extension.

And if it is an On Axis face, check the vertex coordinates with the Tape Measure tool, or by adding a Text box at each corner, to check if the coordinates match.