Why intersection produces empty areas?


#1

intersection.skp (1.4 MB)

The goal I am trying to reach is to create circles on the inner side of the end of the big tube. So I created a plane and want to intersact it. But after I do intersact it and delete the face of rectangle I see that the circle has some gaps. Why is it? How to fix it?

This is SU8 file, because I still use SU8.


#2

Ive never experienced this issue but why don’t you just copy the inner line of the tube and move it to the area you need? Seems like it would take less time than intersecting faces.


#3

turn on the hidden Geometry. You can see there will be lots of very short edges where the plane crosses the softened edges. These edges are going to be so short, SketchUp won’t fill them in.

You could work with the model scaled up by a factor of 100 or 1000 and get around this problem. It would be best to start with a cleaner model.


#4

D’U think this? But there is 0,04 aprox. distance. I expect it should add a line because the surface on the image is flat. There is a face.

The model is multiplied by 100. It is huge


#5

First explode big tube. Then select with plane and intersact it. Delete face.


#6

Thank you. Relatively simple operation. I needed to extend the frame not to touch the tube and explode the group. Now works like sharm.


#7

This topic was automatically closed after 91 days. New replies are no longer allowed.