Surfaces are disappearing when I intersect circles


#1

I have tried many different ways to intersect these two circles and you can see that the face will disappear. I need them to intersect without deleting anything. Can anyone explain to me why this is happening and how I can avoid this?


#2

Could you share the file as it is now, with the face missing?

How large are the diameters?
One possibility is that one of the edges due to the intersecting circles is too short for SketchUp to create/separate the new face. I just reproduced this situation after trying several times.


#3

The circles are about 2mm diameter.

Can you go into a little more detail about the edges being to short? I pretty new to this.

Thank you!


#4

That probably explains the missing face.

If two segmented SketchUp circles intersect, the result may be a new segment that is very short. That is if one segment of one circle intersects a segment of the other circle near an endpoint.
If this new short segment is less than 1/1000", then SketchUp can’t create a face.

See what size the shortest segment is.

To workaround this, draw at a larger scale, say 10x or even 100x. After intersecting both circles you can scale down to actual size.


#5

There is another important property of the circles, which you haven’t mentioned.
That is, the number of segments.

Obviously, higher and higher segment counts equate to shorter and shorter segments.
In the screenshot you shared, it’s apparent the circle segmentation is set far beyond the 24-segment default.

Consider circle and arc segmentation settings carefully with regard to the end use of the model.
A model for 3D printing might benefit from higher circle segmentation.
A model intended for presentation will only suffer performance issues as (unnecessary) complexity increases.