Disappearing Faces


#1

Good afternoon all

So I’m creating a new model with a number of very simple completely flat faces and when I copy the components over to duplicate one of the faces on each of the inside components disappears - very odd !

I’ve tried fixing problems (none) and purging unused and still this is happening.

Any ideas ?

also - when I try to intersect the faces with one another - they are not creating lines around all of the faces … I want a ‘hole’ where the bits stick out … if that makes sense.

So two problems really - but the same model so they may be associated.

DELETE ME.skp (1.7 MB)


#2

You have 206 components in your model. Which one were you having trouble with?

Naming your components would make it easier to pick them out. Is it the one called “Component #372”? It has a missing face and reversed faces.

I’d recommend turning length snapping off as every time someone posts a model here with this type of problem they have it on. I think lines are snapping to the nearest mm in preference to the same plane as the other lines. Within a certain tolerance of about 1/1000 inch, SketchUp treats points as being close enough to being in the same plane and forms a face.

You also have geometry on layer “* glass” which can also cause problems. It is better to leave all edges and faces on layer0 and assign layers to groups and components. At least until you know the consequences of doing so.

I’ve cleaned up that component which had stray lines and the bottom face wasn’t flat even though SketchUp did form a face.
Flat Panel.skp (17.3 KB)

Could you show an example of just the two components you’re trying to intersect?


#3

Good afternoon

Thank you so much for coming back to me so quickly ! So that was the problem - I understand now. How would I go about turning the length snapping off ?

That has actually solved my other problem so not to worry about that.

Again - thank you so very much.


#4

Open the Model Info which you’ll find in the Window Menu.
Then click Units at the left, then untick the “Enable Length Snapping” box.


#5

Amazing - got it, thank you.


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.