Why does validation of my extension fail because of encrypted files?


#1

We’re receiving the following error message by the automated test system after submitting. My developer believes we have no .rbs or .rbe files in our .rbz.

“.rbs and .rbe file extensions are not allowed in the .rbz package. Please remove those files and include only unencrypted .rb files (and of course all other files your extensions needs). Select the type(s) of encryption you would like and we will encrypt your files for you. All .rb files, except for the root .rb file, will be encrypted.”


Extension Warehouse Validation is broken
#2

it’s easy to check what is in the rbz ‘folder’…

rename it replacing .rbz with .zip and then unzip it to see it’s contents…

john


#3

Thanks John – we have done that, and found no .rbs or .rbe files in the contents of our .rbz. That is why this error is confusing, and a bit of a challenge for us.


#4

I do not know what is used in the file transfer used but the CRC , zip codes are not very robust for a error detection and correction stand point. I recall a posting where in the use of certain hash codes was discontinued.
Have you tried to resend and check what hash code error detection is used??


#5

What software are you using to make the RBZ ?
I assume you are compressing the loader RB and the one subfolder of the same name, into a ZIP file and then changing its file-type suffix to .RBZ ?

In very early testing of the signing process I recall some issues with ZIP files made with some more obscure compression utilities.
Surprisingly the exact same files can ZIP with subtle differences, sometimes throwing the signing code off kilter…

I always now use ‘7zip’ which has proved very robust and I have not had any issues with RBZ files made using that…
http://www.7-zip.org/


#6

The superficial answer is that something in your rbz looks like a rbs or rbe to the validation handler at Trimble. TIG mentions one possibility: their zip handler and yours aren’t quite compatible. Try a different one and see what happens. Another possibility is that you have binary content in your file set (e.g. images, compiled code, already zipped files, etc.) and one or more of the files are fooling the validation system. Most systems rely on a “magic” sequence of bytes at the start of a binary file to determine its type, and one of your files could accidentally match what they are looking for as rbs or rbe. In the end, only the folks at Trimble responsible for the validator can say for sure.


#7

Hi, guys.
Could you please clarify the version of 7zip you recommend to use?
So the *.rbz file submitted to Extension Warehouse was created by 7zip but I tried to do this with different versions and got the same archives (size and content) but with different checksum.

Thank you.


#8

I successfully use 7zip 64-bit version 16.02 - the latest version.
Have you also tried the Windows built-in Send to… > Compressed folder tool.
This should also be relatively foolproof, but I think it’s less flexible that 7zip


#9

I keep getting this error as well. I have tried submitting the same extension over 20 times now using different compression tools, trying to remove different files in the source code and even tried submitting by another name in case the files from previous passes weren’t purged in between. I keep getting that annoying error message about RBE/RBS files being forbidden. Does anyone know if this is just some sort of default error message that you get for various completely unrelated issues?


#10

A simply compressed .ZIP file, which is then re-suffixed as .RBZ should work in the ‘signing’ process ??
I use 7zip and have not had any issues for more than a year…

Although one oddity is that the returned ‘signed’ RBZ contains an unexpected ‘.’ folder, but I usually delete that…

The only prohibited files in the ‘upload’ are RBS and RBE - all scripts must be RB.
You can include other file types - e.g. JS - which will also be hashed…

NO previous versions should be ‘kept’ as it is the avowed and strict policy of the signing-portal that NO submitted files are retained from before OR after processing…


#11

I’m trying to publish on Extension Warehouse, not sign the extension in the signature portal. I have already published 52 extensions successfully but have gotten the RBS/RBE error a number of times. Usually submitting again fixes it. This time it doesn’t. And of course I don’t actually have any encrypted ruby source code files in the extension. I hardly think anyone who gets this error message has.