Why do windows switch when using measuring tool

Hi I am having a issue with ketchup pro switching windows when I use measuring tool. Previously fine working on os x el captain, then suddenly started to play up.

This sort of thing has been reported numerous times. It isn’t specifically related to the Tape Measure tool. To quote @slbaumgartner from an earlier thread:

"it sounds similar to the issue several people have reported when using multiple monitors or multiple virtual desktops (“spaces”) in Mac OS X. "


“Choosing “assign to this desktop” from the dock options menu fixed it for me.”

“With SketchUp in the dock, right-click the icon and choose options.”

Hi thanks for the reply. I have done this and on startup worked but has soon reverted back.
Sometimes my windows just have a tick next to the one in use and other times one has a dot and one a tick and this is when my issues start. Any ideas what relevance the dot and tick have?

are you using ‘full screen mode’ on any of your open models?

they are also additional ‘separate windows’ and cause issues with SU [and some other multi document apps]…

I haven’t been able to reproduce more than a tick, are you using more than one monitor?


FYI, I believe this is one of other threads @DaveR has mentioned.