Why do my flat faces suddenly end up with hidden geometry


#1

I have been using Sketchup for a while but am occasionally frustrated by a flat surface that suddenly ends up not flat (with a bunch of hidden geometry). It seems like this would be a common issue but I am not finding an answer when searching. It is hugely frustrating!


#2

Can you post some screenshots or a video of what is going on? Better yet, can you post the file so I can take a look?


#3

This is called triangulation.

In SketchUp vertices stick to each other, if the geometry is in the same entities context. Moving one of the faces vertices with the MoveTool, will create a non-planar “auto-folded” face, such as you describe.

To separate geometry, select it and choose either “Make Group” or “Make Component”, from the popup context menu.


#4

I am pretty careful dragging geometry around. Are there other ways this happens? I am using Pro and doing a lot of Unions and Subtractions and the like. Here is the problem part: https://drive.google.com/file/d/0BxF8IoGgsWZwSmg1dV9MeFhJNFE/view?usp=sharing


#5

From what I can see, your model geometry is slightly off in a few areas. You say you are being careful when you move any of your geometry, so I will assume that is not what is causing the problem.With that in mind, the next most likely problem is a mistake when the geometry was created.


#6

[quote=“C13229, post:5, topic:28660, full:true”]
From what I can see, your model geometry is slightly off in a few areas. You say you are being careful when you move any of your geometry, so I will assume that is not what is causing the problem.With that in mind, the next most likely problem is a mistake when the geometry was created.
[/quote]Sooo…when I do a “Union” of two parts that are off by a tiny bit the operation results in all the hidden geometry? Should that be happening? In any case, if that is what happens, and here is the “oh ■■■■ I am an idiot moment” if I simply had “View”, “Hidden Geometry” on when I did the Union I would have known and been able to fix things…?

Thanks,
Will


#7

I was able to salvage some of your geometry and clean it up for you. I had to get rid of some parts and if you need them you will need to re-make them. I could do a bit more work and salvage more of the geometry but I don’t have time to work on it at the moment. Anyway, here is the file for you if you want it.

Problemfixed.skp (54.8 KB)


#8

Casey,

Thanks for taking the time, two questions…first, I did not think the geometry would be recoverable. Is there a writeup somewhere that talks to how you did it? second, is 17 in general release?!?

Will


#9

No, 17 is not general release yet. I was running some export tests yesterday and must have used the wrong settings. You can go ahead and delete it. This file should be openable.

Problemfixed.skp (54.8 KB)

As for how I did it, I drew a flat, perfectly straight face along your geometry and then used intersect face to generate an outline of the geometry on the new face. Then I used push/pull to give it depth.


#10

Thanks, very helpful.Will


#11

This happens sometimes after you do “Intersect faces”.
It’s always good to have Hidden Geometry switched on when you are doing this.
It may indicate some slightly dodgy geometry but sometimes it just happens.
Particularly if you’ve been using “Intersect faces” a lot.

You can either delete the extraneous dotted lines, if this works without losing faces, or use the Erase tool with Shift and Alt (on a Mac) to make a dotted corner line into a proper one, or just draw a line over it with the line tool.


#12

This happens to me sometimes on a DWG import. Good to know I can just erase the dotted lines.
Thanks,
M@


#13

Well, you can if they are flat faces. But if deleting the dotted line removes the face, it wasn’t flat to begin with and you may need to fix that, or just hide the fact again with Undo.


#14

This happens to me too sometimes after using Intersect.
I now always check hidden geometry after using Intersect and try to avoid using it at all.