Flat surfaces inexplicably explode into triangular subsurfaces


#1

I build a wall in sketchup, and after pushing/pulling windows and door openings, somehow, the wall breaks up into triangular subsurfaces. These subsurfaces aren’t visible until i try to select the wall. Is there any way to fix this without redrawing it?


#2

Without your actual model it is a guess , but almost certain in the PP operation your distorted your model and the tris are a result of SU doing what one would expect which is auto fold to maintain surfaces. With out redrawing hope you have auto save set other wise once you save in that condition you are down the road. Since you have use groups which helps with geometry isolation the correction may not be tool painful


#3

Since the window structure at the bottom of the triangular area is too complex to have push-pulled it through the wall (you can only push-pull a face), you have to have done something more than you have told us. What detailed process did you follow to create that window? Possibly something was subtly out of alignment when it intersected the wall.


#4

Bourne2.skp (2.3 MB)

Here is the model, The stone columns are a separate group. I drew the walls, then drew a rectangle on the wall surface, and pushed it thru the wall. The wall is still completely flat/planar. The top of the wall does have a complex slope to it (the interior face of the wall is slightly shorter than the exterior face).

Its weird, because this already happened, and i redrew it. With each window i drew the second time, i kept checking to see if the surface was still whole, and it was. I made some changes to other parts of the model, and came back and it was exploded into triangles.

If the alignment is off, then the triangles would show up with lines at the edges, right?


#5

No–they are either hidden or softened. You can see them and operate on them by going to View > Hidden Geometry, a toggle, and a handy enough command to warrant a shortcut key.

-Gully


#6

I noticed that if i triple click and select every part of the wall, the triangular shapes show up, I drew lines over the triangular intersections, then erased them, and it went back to a single solid surface. Thanx for the help everyone


#7

That’s like lighting a stick of dynamite to illuminate your door lock at night. Much better to use View > Hidden Geometry.

-Gully


#8

keegan:
Have you noticed if one dispalys the terrain some windows and doors are under ground.
I also question all groups are on layer zero??


#9

@keegan,

I just had a chance to glance at your model and thought I’d mention that hiding is usually used only for temporarily gettings out of the way.

In terms of selectivity and predictable operation, using layers is much to be preferred.

Hiding faces can be especially problematic, because View > Hidden Geometry renders hidden faces as a fairly dense grid, distracting at best.

Also, by hiding the Google Earth Snapshot and Terrain, you performed redundant effort, since their layers could simply have been switched off.

Incidentally, I was able to get rid of all those crazy hidden lines with no obvious damage to the model, once I was able to see what I was doing.

Before:

After:

-Gully


#10

Keegan:
Same here, but there are a number of other issues like beam at left side sticking thru wall, some edges not intersected.
IMHO you should learn to use components think they will serve you better than all the groups, naming would also help.

BTW my younger daughter graduated from Fort Lewis is now principal at High School in Glenwood Springs.


#11

[quote=“Gully_Foyle, post:9, topic:14749”]…
Incidentally, I was able to get rid of all those crazy hidden lines with no obvious damage to the model, once I was able to see what I was doing.
[/quote]
This may be true but are remaining edges coplanar? Isn’t the fact that you could erase displayed hidden edges without loosing the surface just because all errors (not coplanar) are within tolerance of keeping that surface?
Reason I ask is that I checked the east side wall and there are lots of endpoints not in one plane in its outer surface


#12

Not sure I follow. Please elaborate.


#13

Change unit settings to decimal and mm and highest precision for displaying values.



The first image shows the original geometry with hidden edges displayed

The second image has these edges removed. The surface remaines and is selectable as one face.
However, endpoints are not coplanar, measured along the bottom/left face normal, the blue axis.


#14

You talking about the variation in the circled numbers?

-Gully


#15

Thanks for the tips, that model is still early in the design process, and Im just placing beams, etc, so i haven’t intersected everything yet. I usually build build build, then go back and assign layers, then set up scenes to go to layout. Should probably setup a template. Small world, lots of people are connected to this area.


#16

I didn’t realize that there was so much trash hidden in the model. I will definitely stop hiding so much stuff. I do use components, but with the wedge shape of this house, most of these pieces are tapering etc., again, thanx for the tips


#17

Yes, they should be equal to zero, the X values in your rotated surface.


#18

Yeah, I agree. So what do you propose?

-Gully


#19

To you? … nothing. To @keegan, remodel at least that wall.


#20

Well, that’s a relief.

@keegan, he’s right, of course.

Remodeling something a few times until you get it right can be very worthwhile. Each time, the quality of the model improves and each time your skills improve. Compare that with trying to tweak and band-aid something that somehow got screwed up when you weren’t looking. Not only do you end up with a defective model, you still don’t know how to do it right.

-Gully