Subtriangle of faces

mesh

#1

Hi i use sketchup and i want to see subtriangles of faces. how can i see them?
sketchup use subtriangle for face by Default?
I think that in the 3dmax faces are made of two triangles. sketchup is not same?


#2

For non-planar faces, you can see hidden lines by turning on hidden edges in View Menu > Hidden Geometry. e.g. draw a circle, push-pull it up into a cylinder. With hidden geometry on, you’ll see the cylinder made up of rectangles on the sides and one flat circular plane on the top. It never shows you the triangles those rectangles are made up of or the triangles the circular plane is made of.

For a flat face e.g. a rectangle SketchUp never lets you see the triangles that it is made up of even if it is storing them as triangles internally or at least sending to openGL that way.


#3

SketchUp Faces can be any closed planar shape, they are not required to be triangular. So unless you have somehow created triangles, there won’t be any subtriangles to see. There are various ways you could get triangles. Many ways of creating a mesh in SketchUp (e.g. the sandbox tools) will automatically construct it using triangles. There are subdivision extensions that will triangulate a surface. A somewhat heavier way is to export the model as a stl file and then import that stl into a new SketchUp model.

As @McGordon alluded, in SketchUp a “surface” is formed by a collection of faces in which the edges between the faces have been “softened”. The soften setting tells SketchUp to consider the adjacent faces to be portions of a single surface. Often the edges will also be “smoothed”. The smooth setting tells SketchUp to use blended shading across the adjacent faces to make them look more like a curved 3D surface instead of having a crease where the shading changes abruptly. Edges that are softened and smoothed don’t show on the display unless you select View->Hidden Geometry, in which case they show as dashed lines.


#4

Thanks guys. :rose:


#5

I used vray 3.4 and Edges map for diffuse of material. By enabling Hidden Edges Option , now I can see a line on the face?
sorry for my bad English


#6

As @slbaumgartner noted, SketchUp deals with bounded polygons in its own way. However, as you’ve discovered, the triangulation can be seen when exported and imported into other software viewers. For example, this SketchUp object (created using 48-segment circles):

image

Looks like this if it’s exported as an STL file and then imported into MeshLab:

image

Or Vectary:

image


#7

Which means that the surfaces are formed from triangles , but we are not able to see it in sketchup by Default ?


#8

No. The examples @jimhami42 showed illustrate the triangulation created when a SketchUp file is exported to a format that only supports triangles, such as stl. As I wrote earlier, SketchUp allows planar polygons of any shape, not just triangles.


#9

But in my example vray rendered plane in triangulation.
Wen I enabled Hidden Edges Option.
I 'm confused . :frowning_face:


#10

I am of the belief that the internal SketchUp faces are stored as bounded polygons and triangulated when needed. The API structure supports this model as do most graphics libraries.

Following up on my earlier example, here’s a similar object exported as an STL file:

image

If I rotate it about the origin and export it again, I get this:

image

Note that the same shape is triangulated differently depending on the orientation. If SketchUp internally triangulated everything, then the orientation wouldn’t make any difference.


#11

It may be a matter of how you are thinking about it. Any surface in SketchUp may be divided into triangles, but has to be divided only if it is not planar. The seeming rectangle you showed is likely not planar and has been “folded” into two triangles. SketchUp won’t show the fold (a soft and smooth edge) unless you turn on View->Hidden Geometry, but when imported or rendered the fold may become visible.

PS: I don’t use V-Ray so I don’t know what it may do to a SketchUp face during rendering.


#12

I use KerkyThea for rendering, and I’ve noticed, from time to time, that noticeable artifacts are sometimes created by triangulation. This is a bit hard to see, but the streaks between the holes is the undesirable effect:

image

Again, I believe this is a result of the KerkyThea for SketchUp exporter and not a SketchUp thing.


#13

Here is a test you can do: with Hidden Geometry still enabled, select and delete that diagonal line. If the two triangles on either side disappear, it means that the four corners of the “rectangle” are not co-planar, and therefore it is impossible to span the “rectangle” with a single flat face. If the two triangles remain (and in fact merge into one face entity) then the “rectangle” is actually a rectangle, and the diagonal edge was not necessary in order to form the face.


#14

More DHB**

SketchUp:

image

KerkyThea:

image

** Dead Horse Beating


#15

This diagonal line is shown in the rendering image , and I will not be able to select it in the viewport.


#16

At the risk of causing further injury to the poor horse.

Here is a flat square exported to stl then reimported.
It now has a diagonal line through it. Sketchup doesn’t need the diagonal, but stl and other formats do.
So if the model is created and stays in sketchup there will be no diagonals to see.
stl


#17

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.