WHY did I spend $120 on this?

I’ve been using SketchUp off-and-on in its various free platforms for several years. It has proved invaluable in mocking-up woodworking projects and determining how much material I need to buy.

So, when I opened it recently and found that my Free Version no longer worked, I had to consider long and hard whether to purchase a paid version. Eventually, I decided that I’ve ridden the Free Train long enough and $10 per month was justified. Even though I don’t use the software very often, I would still get my money’s worth out of it; and if I didn’t, I could comfortably chalk the cost up to the free use I’ve already utilized.

Here’s the problem - it doesn’t f**king work! Like, at ALL. And the “help” section is pretty much useless, too. So I’m turning to the Forum for answers before I demand a refund and find another program.

I can’t so much as draw a simple rectangle to begin my project.

To be clear - I’m familiar with the Tools, the keyboard shortcuts I most often use, etc.

I had expected to have a seamless, optimized experience after laying down money for a program that I’ve always used for free. Instead, I’m dead in the water.

Is there something I’m missing, or doing wrong? I thought that once I reached the template, I would be good to go.

So far, I’ve opened one project and had zero functionality. So, I opened Sketch-Up again via the email Trimble sent. That one worked for about 10 minutes before breaking. Since then, I haven’t been able to do anything.

Can you describe exactly what happens when it “breaks”?

The template opened, I selected and erased the default figure at origin. Then selected the rectangle tool and drew a rectangle. I then used tape measure tool to lay out guides for an octagon and connected the guides with the Line tool. Erased the triangles and made the shape a Component. Used the Offset tool to step-in the octagon 3 times. After using Push-Pull on the Center octagon, I realized I had made a mistake by not adding additional components (I’m still learning), so I “undid” the last few steps and started over with the initial rectangle.

I don’t remember exactly when it happened, but somewhere during this procedure, nothing I did within the UI frame had any effect. I could switch between tools, I could Pan and Orbit - but the tools didn’t do anything. I tried to randomly draw shapes, dimensions, guides, etc. My mouse would move the cursor and select tools, but the tools themselves wouldn’t do anything.

After posting this thread, I started over and so far it seems to be working… but I’m leery and just waiting for it to crash again.

I’m curious what you mean when you say your free version stopped working, what free version was that and why did it stop working?
There is no reason for any version to stop working as such from the sketchup end, in fact it is still possible to download a free desktop version, for non commercial use.

I think I had SketchUp Make 2017. All I can tell you is that when I open SketchUp (or any of my designs), my browser opens to a page that tells me my version has expired. Yes… this means I can’t even view the projects I’ve previously designed. Super awesome.

From my experience, you can still download the Free version for 30 days. I’m not interested in creating multiple email accounts, just to get free software every month.

I’d be fine with the $120 price tag if the program actually worked.

Update: Since posting this thread, I’ve been working with the paid version again and it hasn’t completely crashed, but it is more glitchy and frustrating than the Free version.

It’s not like I’m even pushing the limits… I only use it to help me design simple woodworking projects.

I was fine with the free version being buggy and unreliable. I have less patience now that I’ve paid for it.

As a Craftsman, I will never understand this concept of bringing a product to market that doesn’t work, nor why people put up with it.

If I quote a price for my work and fail to deliver, I lose the client - and likely others who might’ve hired me via Word of Mouth.

Why should software companies have a lower bar?

Are you sure it wasn’t just telling you that the pro trial had expired? The Actually SketchUp 2017 Make version doesn’t expire.

You seem to have a skewed experience. When you initially install SketchUp 2017 Make you get to use the pro version for 30 days. After that it reverts to SketchUp Make.

SketchUp Shop will work just fine. I use it regularly and have no problems using it.

From what you describe I have to think it’s not a problem with the software. It doesn’t reflect my experience at all. this is an example of something model in SU Shop.

Here’s another.

Understood. Of course if you’ve been using SketchUp Make or SketchUp Free you shouldn’t have been. And if you are doing work for clients, you should probably be using SketchUp Pro instead of Shop so that you have access to LayOut, too.

When SketchUp Make runs through its 30 days of Pro features, there is an I Agree button in the welcome screen, that many people don’t notice. I you see that, and click on it, your SketchUp Make will continue to work.

You should try that, and see if it works. If it does, and you don’t need to use the Shop browser based version, you have up to 14 days to ask for a refund.

If you currently are using a 30 day trial of SketchUp 2021, make sure to Save As… any files that you want to continue working on when you’re back using SketchUp Make 2017.

Or keep using Shop, and try a different browser. Thing are improving, but for a long time Shop has worked better in Chrome than in Safari.

SO, you’re saying that our experiences are different and you disagree with my choice of versions.

I promise you that my version of Make 2017 was marked “expired”, and I was directed to a “purchase only” model.

I have no doubt that the software works for MOST people.

I came here looking for help that wasn’t available from Trimble. By “help”, I mean advice/assistance in solving my problem.

From you, I got: “It works fine for me.”

On what planet does that help me solve my issue?

Yes. I am saying our experiences are different with SketchUp Shop. Just for the heck of it I did this after I made my previous post and took the dog for a walk around the block. Shop never locked up or otherwise quit working.

Show the screen you were seeing. As I wrote before, SketchUp Make does not expire. The pro trial does expire and after that you’ll get a message saying the pro trial has expired and encouraging you to purchase Pro but you can click through that.

I don’t disagree with your choice of Shop. Since you are using SketchUp for projects for clients you need to be using either SketchUp Shop or SketchUp Pro. SketchUp Make and Sketchup Free (the web-based free version) are not appropriate choices because they don’t provide you with a license for your commercial use of it.

Your post indicates that you believe SketchUp Shop does not function. Period. I only stated that your experience doesn’t match mine. I would be happy to try to help you but you’ve made it clear you aren’t interested in my help so I’ll stop now.

Something occurred to me. There were two versions of SketchUp 2017, Pro and Make. With Make you could either add a serial number and it would become Pro, or you could agree to the terms and conditions after 30 days, and it would remain as Make. Pro was different, after 30 days it would expire, and not become Make, and it would say it was expired.

You can download Make from here, and it will continue to work after the 30 days are up:

https://www.sketchup.com/sketchup/2017/en/sketchupmake-2017-3-116-90851-en-dmg

One part I may have missed, when you said you use SketchUp for your small woodworking projects, that sounded like it was to make things for yourself. If you are going on to make and sell furniture to other people, and if Shop isn’t up to the task, your best option is to pay for SketchUp Pro. Then the license covers you for earning income from your use of SketchUp. Hopefully in a year of work you will be able to account for $300 worth of profit that you made, that you wouldn’t have made if you weren’t using SketchUp all year long.

For what it’s worth, it’s still not working. I can’t so much as draw an 18" square. Beyond frustrating.

What are you doing differently?