Why CPU so high?

Hi! im running Sketchup in my new Macbok Pro (M2 chip) but it has been extremely slow. I checked the activity monitor and saw some crazy CPU numbers.

What is the problem? why the number are so high? Could my model be the problem? Please help!!!

It could be. Share the SketchUp file with us.

Which version of SketchUp are you actually using? Your profile is confusing. There is no Free Plan of SketchUp Pro. Please edit your profile to correct that. Also, put the operating system in the Operating System field, not the SketchUp version.

Keep in mind that SketchUp 2023 does not support the current Mac OS so that could be an issue.

Hi! Thanks for the reply! i got the free 7-day trail for sketchup Pro. Heres a photo of the version.

Im about to send you the model

That’s still SketchUp Pro not the Free Plan. The Free Plan is the web based version.

That’s unusual, the current Mac version is 23.1.341.

I think that i dont have the last version, when i first used Sketchup I do received a notification of a new version but simply ignored it.

Where’s your model file? If it’s larger than 16 Mb upload it to DropBox or We Transfer and share the link.

Why would you just ignore that?

Im currently downloading the file to Dropbox, please wait a few minutes.

Hi, heres the link:

Well, I think you can blame at least some of the issue you’re having on your model.

Incorrect tag usage. ALL edges and faces should be created AND remain untagged.
Screenshot - 1_5_2024 , 11_50_52 AM

You’re hoarding a lot of unused components and materials.
Screenshot - 1_5_2024 , 11_51_39 AM

I also did a bit of cleanup of unneeded edges and faces.
Screenshot - 1_5_2024 , 11_59_03 AM

That reduced your file size by over 70%. Bloated files are the main reason for poor performance. You have to manage your models correctly.

Note if you’re planning to use a rendering application with your model, those blue back faces are going to give you problems. You should only have white front faces visible.

Here’s the stripped down model. I set Face Style to Monochrome so your computer doesn’t have to process the textures. You can turn them back on by changing Face Style to Shaded with Textures.

Please correct your forum profile.

1 Like


  1. How do i remove tags?
  2. How can i purge unused components and materials?
  3. Ho do i “clean up” unneeded edges and faces?

I used an extension called Default Tag Geometry from Sketchucation.

You can go to Window>Model Info>Statistics and click Purge Unused. I used an extension called Purge All from Sketchucation because it gives a report to show what was purged.

I used CleanUp3 from The Extension Warehouse.


especially crazy since 1000% means it’s using 10 cores at 100%

however sketchup, like all 3d softwares, is monocore. 100% would have been normal, maybe doing a rendering or something, 1000% is not, and to me it looks a bit like a mac OS bug

I downloaded it, and opened it, and yeah, it runs at around 100% CPU, meaning one core at full clock. it shouldn’t run on 10 cores.

In your profile, under “operating system” it says Sketchup 2023. that’s not your operating system, it should be mac os 13 or 14.
There have been a few occasions after release where softwares would just hog all of the RAM, but CPU… haven’t seen that one yet.

I even made 3 copies of the file and opened them at once, and still it wouldn’t go higher than 100%.

What version of M2 Mac do you have, in particular how much RAM? I’m wondering whether the large model (or perhaps a misbehaving extension) is causing SketchUp to use so much memory that it is thrashing to disk. That wouldn’t explain the weird CPU % , but it would cause a severe slowdown. You should be able to look at the memory panel of activity monitor to check this.

Is everything slow, or just SketchUp?

This is just good practice for clean modeling (until you are an advanced user, and need specific use cases for loose geometry to be tagged.

I’m curious though @DaveR and @colin if this impacts performance

I doubt it affects performance but it’s part of my standard cleaning process. Especially with files such as the OP’s which use a lot of poorly modeled entourage from the 3D Warehouse. There’s no point in having all those tags anyway.

Your model also contains things that will affect performance of SketchUp:

  • Several very detailed entourage components (e.g. the hanging ivy contributes almost half of the geometry in the model, the place settings on the table have about 1/8)
  • Large texture images (e.g. the Bouclé texture’s image is about 10million pixels). SketchUp is going to downsample that even if the max texture size setting is on.
  • Texture images that while not overly large in themselves have absurd numbers of pixels for the size of the material tile they cover (e.g. the VP Ficus Elastica Bark material uses 1.5million pixels to cover an area of 1 sq inch. Unless you zoom in incredibly close, you can’t possibly see that level of detail and the rendering will be a plain color anyway.

It is not necessarily wrong to use these, but you need to be aware that they will strongly affect SketchUp’s performance (and large texture images affect file size).

Hi here’s a photo of the info on the Mac.

I’m curious about the misbeaheving extenison you mentioned. Time ago, I downloaded an extension named “Thea render” (https://www.thearender.com/). I just tested Sketchups CPU in two conditions: rendering (1) and not rendering (2), and certainly you were right. In case 1, numbers exceed the 500, contrastingly, in case 2 they maintained below 100. By the way, the only app that is slow, is Sketchup.

Anyways, for any render extension a CPU above 500% is insane. What is happening with the extension? Could it harm my computer?

The extension is spawning additional threads to do the rendering, and those threads are being assigned to additional CPU cores. Unlike 3D model editing, rendering is suitable for multiple processing threads dividing up the problem and each working on a separate piece. The Activity Monitor reports the total CPU usage across all of the threads, so 500% means at least 4 CPU cores are working on the render plus one for SketchUp itself.

The only way the load could harm a computer is if it led to extreme overheating. Macs are very good about monitoring temperature and slowing down if it gets too high. Unlike on a PC there is no way to overclock a Mac.

your CPU has several cores. like several motors, all independent.

when an application uses 100%, it means it uses about 1 core. If it uses 500% then it uses 5 cores.
your macbook pro has probably 12-16 (I can’t remember the exact setup that were sold in M2). so having thea render run 500% is not alarming, it is simulating light and materials and creating images, so it’s working really hard.

Sketchup is a 3d software, and the 3d modelling technology is limited to one core at a time, so sketchup, at its maximum, can’t run higher than 100% (for various math reasons)
Now, it’s not entirely true, extensions runs inside sketchup, but they are not limited by the 1 core rule. That’s why when you make a rendering in thea render, sketchup goes up to 500%. There is 100% for sketchup and about 400% for the rendering in thea.

What’s surprising in your initial image is that setchup goes up to 1000%
What were you doing in sketchup when you took the screenshot ? were you rendering some images ?

edit : darn, too slow :smiley:

1 Like