White Lines on Round Object when Exporting to PDF

Hi there, currently trying to get a model I’ve done up to export to PDF, but when I export it, some random white lines appear on the round geometries at every edge. I’ve got profiles & edges both turned off & everything looks right in sketchup, but not when I export! Any clues how to render/export this without the lines? See screen grabs below…


This (above) is the geometry once rendered/exported…

Thanks a million in advance!

(EDIT) apparently I can’t put 2 pics in a post… So can’t show you how it looks in Sketchup…Looks perfect in SU though…

OK realised I can just post another reply with the other photo… here’s how it looks in Sketchup… I want my exported image to look like this!

Could you share the SKP file? It appears you’ve hidden the edges and you’re seeing the back face color bleeding through. One option would be to change the style so the back face color is darker.

I’ve pasted the troublesome geometries into a blank file. I’ve double checked, the geometry in some parts I’m having the issues with is only one wall, i.e. has no ‘thickness’, so the whole model is one colour, both sides…? I feel like I must have some settings wrong when I export or something…

Pots.skp (118.1 KB)

I see the same results. If you just need an image you could export as PNG, that doesn’t have the same problem.

1 Like

You’re running into a limitation of the PDF export. You could export to a PNG or JPG and get a much better quality image.

Or, if you need a PDF file, use LayOut which has a better PDF export option.
Screenshot - 8_29_2017 , 9_52_14 PM

1 Like

Awesome, thanks so much guys! Didn’t realise that would make a difference! I was using PDF mostly just because I didn’t like the grey background Sketchup gives with JPEG & PNG… And also the images always seem to be clearer/not pixelated with the PDF export… I might try getting LayOut to resolve that then…

Thanks again!

You can export a .png with transparent background.

Oh really? How?

When you get to the Export dialog, change the drop down to .png, then click the button that says options and tick the box for Transparent Background.

1 Like

In that PNG export options is Antialiasing too, which helps.

The PDF seems to be vectors, which could explain why it seems less pixelated.

:scream: That’s amazing, I feel like such an idiot for never noticing that options tab! haha… Thank you Box!

And cheers, Colin, yeah I had figured that PDFs being vectors was the reason, that was why I had just assumed that the PDF would be better quality overall…Pity their PDF exporter does such a poor job - it’d be perfect otherwise because with vectors you dont get blurriness & the file size is tiny still!!

After some messing around, the quality of files in PNG & JPEG just arent high enough resolution for what I need… I’m trying now to figure out this whole LayOut thing - is it an in-program tool, an add-on, a standalone program? And how do I go about using it? Does it come with SketchUp Pro '15?

Yes layout comes with Pro.
You can use Send to Layout from the file menu to get you started.

1 Like

How much resolution do you need? You can adjust the pixel width for the image.

You can change the style so the background is any color you want including white.

OK cool, thanks for that! I’ve tried exporting from Layout, but now the PDFs seem to be really low quality (even with the quality settings in the export menu set to the highest option) & also the image always seems to have edges turned on, despite my model having edges turned off in sketchup… Strange…

Umm i don’t know in terms of numbers what sort of resolution I need, but basically I need to be able to manipulate things in Photoshop with nice clean selections on any rectilinear components, so that once it has been edited I can print it without any distortion/blur. Also as I’m often presenting things digitally it has to look sharp when zoomed into on a computer… This pic below is the kind of quality I’m currently getting from a JPEG, PNG or Layout export & it’s not sharp enough…Capture

How do you adjust the pixel width?
And sorry, I had forgotten you can change the colour of the background, although the issue is more that I would just rather no background as the images often get laid out in Indesign after editing, usually with some sort of background/image layering behind. Probs should’ve just said that I had wanted no backround haha
Thanks again for all your help!

When you insert the model into LayOut, it is rendered raster by default, this could be your problem.

In LayOut. Highlight the viewport then go to the SketchUp Model tab. You will see the raster render option selected, change this to either vector or hybrid (hybrid to keep any textures).

I don’t know if this is the problem, but it’s a thought.

1 Like

Awesome, thanks!! Would never have thought to look there for those settings!! That has helped the blurriness (and means I can get rid of the background again!), but I still have the black lines for edges… I’ve reduced them down to the minimum size LayOut will let me do (0.01pts) , but they still seem reasonably thick? They certainly seem thicker than 0.01pt to me & I’d rather not have them there at all, if possible… Is there a way to remove them alltogether? I have edges turned off in sketchup when I exported it…

I take it your doing this in the SketchUp Model window, same as the render?

Back in SketchUp. In the styles window, make sure you are in the “in model” styles tab. You can edit the style you are using.
Select the edge settings for the style and make sure edges and profiles are unchecked (I think you can do this). When you have made a change to the style, you have to update it by clicking the circular arrowed thumbnail.
Make a scene and save the SketchUp file.
Back to LayOut, select the viewport > right click> update model reference this will update it to tie in with your new version.
With the viewport still selected, select the scene you just made from the SketchUp Model window.

BTW The correct way to send to LayOut is using scenes, not the last saved SketchUp view, if you were doing that. It keeps the files better connected in the long run.

I hope this makes sense and helps, it’s much easier than I make it sound.

1 Like