While attempt drawing a straight line, it "breaks" and snaps unintentional


#1

Hey there,

I stumbled on a problem while attempting to draw a straight line on a face. Up to a certain distance, it breaks into two lines and snaps to a nearby vertex. To clearify that issue, I made a tiny video which hopefully visualizes the problem.

Any hints on this would be much appreciated. Thank you in advance.


#2

I have never experienced this behavior (that the line breaks and is not straight anymore).

But one thing is less then ideal: You are drawing in a scale of < 1 mm. SketchUp is a program to design buildings and even city quarters. Numbers in computers are limited to a certain precision (or rounding error), and in SketchUp things get unprecise < 1 mm or > 1km. Very strange things can happen and it becomes difficult to close or intersect faces etc.

To model very small things (gears of a swiss watch), draw them at a larger scale as a component and downscale them at the end if necessary. For example draw in meters and think 1 m in the model as 1 mm in reality.


#3

I think Aerilius is right and your model is to small.


#4

Hello there, thanks for your replies and participating in this issue!

Even though I get your point, I can’t understand two things:

  1. The reason why I am working in such small scales is simple: I am creating a model to be printed with a 3D printer. In my case, it is an Ultimaker 2 with a layer resolution up to 20µm for instance. Compared to this, having a precision of 1mm would be way to rough. If I were using a random software which simply isn’t capable of being that precise, I would be ok with it, but here we have Sketchup which claims to be able to serve as a program to create models for 3D printing and even provides a specific template for this case (which I am using by the way).

  2. Spoken in a technical point of view, for me there is no sense in this behaviour. Sure, I have no insight in the Sketchup’s implementation details but If I would try to store such a straight line on my own, I would save it as its start and end point or as two vectors (one from the origin to the start and one from the start to the end) or something like this. Thus I don’t get it why there could be such a behaviour (creating an additional vertex and snapping it to a nearby vertex) simply by accident, completely without any reason.

Assuming that I don’t miss something (please tell me, if that is be the case), I would guess I stumbled upon a tiny weired bug.

Any further hint or suggestions?


#5

As said, it is not ideal to be at such a small scale while using the drawing tools. You can then downscale the model just before sending it to the printer.

SketchUp has been created long before it was found useful for 3d printing. Of course nowadays when designing a new program, one would probably take different decisions and finetune parameters differently.

When you draw an edge, a lot more happens then just storing two points: There are these features that make modeling in SketchUp so special and convenient: snapping, automatic edge merging and breaking (instead of allowing to overlaying geometry), and the internal tolerance (to detect floating point coordinates with rounding errors as being the “same”). This comes with little performance cost and issues at small sizes. In your case the edge was falsely recognized as overlapping the neighbouring edge, and SketchUp broke it and merged it with the nearby vertex.


#6

Click … Window > Model Info > Units
Set Units to meters
Set Precision to 0.000m
Model as though working in mm units.
Scale the model down 1000 : 1 when finished.

-Geo


#7

Hello,

thank you very much for your replies! As Geo suggested, I had a look on the “Model Info” window and the shown settings were even more precise as you wrote:

Should I change them anyways?

Thanks in advance.


#8

The problem is not about changing a setting, but that you are drawing very small things.

The “precision” in the screenshot is how detailed SketchUp displays numbers. It does not change the numbers themselves that SketchUp internally uses. Setting the displayed numbers to more precise does not fix your problem.

The idea is that you draw your model bigger (like 10×, or for simplicity 1000×), but imagine it was smaller. Geo suggested to scale the model by 1000× and use meters as displayed unit. Then you just imagine there was a second m, and you have your “mm”.