Which hosts/IPs to allow through Proxy for license authorization/activation

I think it checks if it is licensed, first, and if not, then checks if you are online to get the activation.
It used google.com or bing.com to ping to.

jbvbnm

Ok that would make sense.

I’m far from an expert but in my attempt at packet sniffing I did see requests to bing.com so that could be that.

It also appears to make requests to client.sketchup.com, not sure if that is part of the activation or if that is just Sketchup looking to see if there are updates.

I have a question as well about this. In a secure environment such as render1, can bing and google be replaced with a different destination (i.e. autodesk.com, adobe.com) as those are already whitelisted through our firewall and the google and bing pings pose a security issue with our vendors.

This is still unresolved for me.

I have gotten quite a few destinations allowed through the corporate proxy, and Sketchup still thinks it is offline and allows no action beyond this.

Has anyone else gotten something like this working?

Ideally if there were a list of the destinations/addresses that need to be allowed through the proxy then I could just get these added and then I could get this activated and working.

Is there someone from the Sketchup team that might be able to look into it? I’m sure this would also help others running into the same situation.

Here is something from the help article. If you follow these steps you can get SketchUp to check your Intranet as a way to see if you are online:

  1. Open a File Explorer window.
  2. Copy and paste this text into the path field in the File Explorer window (replace 20## with your SketchUp version number):

%LocalAppData%\SketchUp\SketchUp 20##\SketchUp\

  1. Open the PrivatePreferences.json file with Notepad.

  2. Locate the line which looks like this:
    "OnlineTestURL": "",

  3. Change the " " value to a URL that you can reliably contact without any kind of redirect or Proxy interference. This could even be your company’s Intranet site. For example:
    "OnlineTestURL": "http://intranet.mycompany.com",

  4. Save the PrivatePreferences.json file.

1 Like

One thing, SketchUp needs to be closed when editing the .json file, otherwise it gets rewritten upon closing again.

@colin Thank you so much! This works!

I closed sketchup, and changed this value to point to an internal address.

I fired up Sketchup, and it immediately indicated that I was online and had the option to sign in.

Clicking the Sign in button takes me to the trimble sign in page, which, with this address allowed through the proxy, it shows up and I am able to log in successfully.

Thanks for your help with this, I really appreciate it. I did search fairly extensively for this issue, but did not find any links to it in the documentation, so I must’ve been using the wrong keywords.

So it looks like the steps to get this working are:

  1. Allow the specific address(es) through corporate proxy
  2. Activate/configure proxy to be used on current workstation
  3. Change ‘OnlineTestUrl’ as above
  4. Fire up Sketchup and log in
  5. Push/Pull to your hearts content
1 Like

This doesn’t work for us. Whitelisted all domains, added in ports as detailed, tried changing the Test URL - etc; still no luck.

We are using a Sophos Web Appliance. Running in Explicit mode.

All we ever get is this:

I’ve tried contacting SketchUp directly for support but have had no response at all. I’ve been in contact with our reseller who has done everything within their power but is unable to help us any further. Can anyone else please advise? In this day and age, software like this should be made proxy aware - especially when being installed in a school environment.

I have Sketchup Pro 2021 and can confirm that it does use the proxy successfully – I have the proxy configured in the Windows 10 proxy settings and Sketchup uses this proxy automatically without any custom configuration.

From the screenshot you posted, it looks like you are attempting to use a ‘Classic’ license, which I think were cancelled by Sketchup ( see SketchUp Classic License | SketchUp Help ).

Do you have a Classic license or something else?

It was a pain for me to get Sketchup working over a proxy, mainly due to the lack of documentation on what needs to be done, but I did get it resolved in the end.

Hi render1,

We have the proxy configured in Windows 10 Proxy settings and within IE, all functioning elsewhere absolutely fine.

Yes, that’s right we were given Classic licenses - the documentation mentioned dropping them into the following location:

C:\ProgramData\SketchUp\SketchUp 2021\activation_info.txt

The MSI is rolling out too via a GPO, no issues that side.

It does seem interesting from the link you’ve given that classic licenses appear to no longer be in operation… however when installing on my PC in the office (bypassing the proxy) using the same MSI / txt file it works fine and activates with no trouble.

It’s as soon as it hits the Sophos Web Appliance we encounter problems.

I’ve contacted Sophos hoping that they’ll come back to me with a resolution, but based on previous experiences with their support I’m not holding out much hope!

They are not longer sold. They will continue to work, as long as there is no nuclear attack or something.

@MikeWayzovski Thanks for clarifying that - I was wondering about that myself. And it is probably more likely for the pandemic to mutate into a zombie strain… at which point all bets are off regarding Sketchup working or not.

@KyleWhite We also whitelisted *.sketchup.com as well – I don’t actually know if this is necessary or not, but I have this allowed through my proxy and I am able to connect to the license server.

When you run Sketchup on your own PC (and it works), does it (or did it) prompt you to log in to Trimble? If it doesn’t, then it means it might be accessing a different network location than the regular SketchUp Pro, which requires logging in to Trimble in order to activate it.

We’ve whitelisted *.sketchup.com too; nothing shows as blocked anywhere along the line. I’ve even run Wireshark and noticed that the software goes to a few other URLs and I’ve whitelisted those too. Still no luck.

When I ran it on my PC, it auto populates the ‘classic’ license fields, hangs for a second, then just opens the application as normal.

On the proxy based machines, it auto populates the license fields, then hangs… and fails with the screenshot above.

Thanks for your responses so far!

Are the ports required by network licensing open? (5053 and 50530)

Worth checking if you have a security solution that is blocking certain User agents, the web browser-based parts of SketchUp are using Chromium.

They might produce a similar type of error along the lines of what you are seeing.
This would manifest itself also with 3D warehouse and extension warehouse also not functioning.

Try logging in with a trial account to bypass the network license section and you can get to those areas using the internal browser, you may be able to rule that out as a possibility for error.

Hello,

We are facing this issue, our security solution is blocking the license activation due to the user agent being chrome version 64… Do you know if there is a way to bypass this? Can we manipulate the user agent somehow?

Thanks

I couldn’t find a way to bypass it within SketchUp itself, the last person I spoke to with this issue removed the user agent blocking from their security - as it turned out it actually solved some other problems their users were facing in other software too.

1 Like

We have a customer case going on currently, and they are going to try what Adam was talking about, and that is to let *.sketchup.com queries use the lower Chromium user agent.

I’m curious, is there a global IT push towards setting v88 of Chromium as the minimum version that is allowed through firewalls?

Does SketchUp needs to be closed when editing the .json file?
WILL it gets rewritten upon closing again?