When I select offset tool the line I want to offset get deselected

Just starting with Sketchup

Offset requires more than one edge segment to work. Are you trying to use it on a single edge?


I selected a rectangle

I am trying to draw a 2d floor plan and wanted to offset for wall thickness

Upload your model file so we can see what you are working with.

Are you sure the edges are coplanar?

1st try.skp (173.6 KB)

Are you sure you’re selecting the Offset tool? Is it possible you’re selecting Follow Me instead?

I get this when I do.

By the way, it’s generally easier to do your modeling with the Camera set to Perspective instead of Parallel Projection. Save Parallel Projection for display–image exports or scenes to go to LayOut.

I selected the offset tool in the toolbar and also tried pressing F

Make sure SketchUp is installed correctly. Quit SketchUp, find the downloaded installer file, right click on it and choose Run as administrator. When the option is presented, choose Repair.

Switched to perspective and it works. Thanks, I’m sure I need help again.

1 Like

One thing I’ve noticed with the offset tool is that it’s very tempting to click on the line that you want to offset from, and that then fails. Instead, if you point near the edge you’re working with you will see an inference box on the edge in question, and then you click on the face you want to offset into, and fine tune where you want the new lines to be. In the best of cases you could just double click on the face where you want the new edges to be.

There isn’t anything special about perspective, other than it might have made it easier to accidentally point at the edge itself

1 Like

Thanks again for the tips!