When I apply a material I get a color not a material

Applying materials to my model I get a color not a material. My search for a solution did not find an answer and I found myself spending way too much time searching the internet and forums. Learned a bunch but the problem was not solved.
I then slowly went through all the commands and found that in Face Style, shaded was checked and that if the face style -shaded with textures is checked (View, Face Style, Shaded with textures) materials work as expected, problem solved!

My question is how did I change this setting? I never went to the pull down menu and changed it.
Also I needed to save the changes in all my scenes. Is there a way to group change save all the scenes?
Happy New Year to all
Thanks
Jeff

It could be that you selected a style that has Shaded but not Shaded with Textures as the face style setting. Maybe like the one I show, below.
Screenshot - 1_2_2022 , 7_17_28 AM

Yes that is a possibility but most likely I was just not paying attention and caused myself a long learning session. Hope this helps others.
Is there a way to update all the scenes or do you have to do each one individually?

If you want to use only that one style throughout, delete any others from In Model.

Alternatively you can set the desired style, select all of the scenes in the Scenes panel, click on the Update button and in the Properties to Update window deselect all but Style and Fog. Then update the scenes.
Screenshot - 1_2_2022 , 8_47_06 AM

I have the Styles toolbar displayed so it’s easy to see what face style is active. Actually I created a custom toolbar to eliminate buttons I don’t need from that part of the toolbar but it’s the same idea. I frequently switch between face styles depending on what I’m doing.
Screenshot - 1_2_2022 , 8_49_38 AM

1 Like

Really good points. They will help me up my game for sure

1 Like

Dave, you can also simply select all the scenes or specific scenes and simply uncheck “styles and fog”, then immediately recheck it. Do not hit update and it automatically applies. You can do this for all those parameters.

6 Likes

Omg
Is that The Sketch up Legend Nick Sonder weighing in?!
Wow! :)))