When exporting to EPS (or PDF), the file returns an error when trying to open in Illustrator

When exporting to EPS (or PDF), the file returns an error when trying to open in Illustrator. When I try to open the file in Illustrator, it opens a pop up window - Unknown error - see attached image of error. Anyone know why or how I can fix it? The technical team from Sketchup thinks it might be a Windows Bug but don’t know how to fix it. I had the issue in version 2023, so the recommended uninstalling & reinstalling - so I installed 2024 and tried before installing any of my plugins and still got the same error. So I’ve been exporting to DWG in order to have a vector image, but it exports each line individually and no materials, so pretty frustrating. Any workarounds or fixes you know of would be greatly appreciated!
Screenshot 2024-04-15 195437

could you share both your sketchup file and the eps / pdf ?

what version of illustrator are you running ?

I just exported both pdf and eps and imported them in illustrator without issues, at least on mac.


The sketchup support team was able to export from my file to eps from a Mac - that’s why they think it might be a Windows bug. I’m running the latest version of illustrator.

the question is, is sketchup’s PC exporter broken, or is Illustrator’s importer ? if you share a pdf / eps that won’t open on your PC, at least we can see if it opens on my mac.

if it does, then it’s likely an illustrator problem
if it doesn’t, then it’s likely a sketchup problem.

1 Like

the file that wouldn’t open for me also won’t open for them. i tried it on other computers as well. it’s definitely a sketchup issue not my illustrator. i’d attach here but it says the file is too large.

You can upload it to cloud storage (GDrive, Dropbox, WeTransfer…) make it public and share the link here.

Same here on a PC, no issues (PDF only)

It’s ok the sketchup team already tried to open it and I tried to open it on another computer. I don’t think it’s suddenly going to open for someone else.