2D Export as EPS to Illustrator Problem


#1

Hi There!

As the description says I am having problems exporting from Sketchup as an EPS file. If I export a brand new sketchup file, with minor shapes added or small exports from the 3D Warehouse then the file exports to illustrator as filled vectors. However… it seems as though when the file size increases - i.e I export a larger file from the 3D warehouse then the EPS exports out of Sketchup/ imports in Illustrator as a wireframe.

Has anyone got any clue whats going on? Due to being a new user, it seems that I can’t upload a file right now


#2

Maybe upload an image here and then post the link for us to view: https://imgbb.com/

Or use we transfer and upload the model file itself.

How complex is the model, sometimes I have experienced reverting to wireframe when memory is low, however usually in-window not during export. Maybe the complexity of the edges it too much?


#3

Liam,

Good shout! This is how the eps is importing into Sketchup.

In reality it should a solid like in your screenshot

And here is the file. https://we.tl/I8gEs4i3cm. I can replicate it with multiple files of varying complexity, this is just a random file I’ve picked out of 3D Warehouse. Simple shapes and simple 3D warehouse imports don’t replicate the problem, so I’m wondering if its my PC.


#4

I turned on the default style and I also merged all of the working layers into a single file just to make sure something was not hiding.

It’s was a real pain to open taking several minutes but I think the offending item is the overflow around the pool as it creates a gazillion lines so if you are not running a decent computer it’s most likely going to slow you down.

Here is a close up of the overflow and the layers panel, and also the object count, over 140,000.


#5

Sorry, had to post in two goes do to new user limits.

Here is a simple shape that I can export as expected


#6

Yes as it’s simple but if you look at my example the model you chose is far from simple once you zoom in.

11

Edit: Clarity, it works fine for me and @TheOnlyAaron so I would suspect your computer is just straining with line count.

I would delete the pool surroundings and give it another go, if thats still causing problems simplify the window frames.


#7

This must be related to your computer… I was able to open the file, export as EPS and open in Illustrator. As @liamk887 Mentioned, I, too, have seen things get dropped when my computer is running low on memory…


#8

Thank you! I actually sent that before your post. Well atleast I know its my computer! Time for an upgrade I think.


#9

Thank you! Atleast I know it’s my computer causing the problem. Just out of curiosity, what spec machine are you and @liamk887 running?


#10

It might also be worth while to try updating your graphics driver. Wireframe exports can also be caused by the IntelHD drivers. Or, if I understand right, you are running SketchUp 2016, you still have the option to try turning off OpenGL Hardware Acceleration (Window menu>Preferences>OpenGL).

Another workaround is to try printing to a PDF printer like Acrobat with the “Use high-accuracy HLR” print option enabled. This will create an all-vector PDF that is practically identical in content to the built in EPS/PDF export. Illustrator opens PDF files quite as well as EPS ones.


#11

I was on my Mac Laptop.


#12

Still one thing: If you are running SketchUp Pro 2016, have you installed its latest maintenance release? If I remember right, this behaviour was more common with the initial version, and at least some of it was fixed in maintenance releases.


#13

Thank you every for the help! The high-acruacy HLR worked a treat thank you @Ansii. @liamk887 your computer is much better than mine, so defintely a time for an upgrade. Haha. It’s nearly 7 years old but i’ve upgraded the ram in the past.


#14

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.