What does this message mean "An internal entitlement management service error has occurred"?


I would appreciate some advice on what to do about this message I’ve got today when trying to use SketchUp. It asked me to log in to my account but when redirected to my internet browser to log in to my Trimble account I then got this message on my SketchUp programme - “An internal entitlement management service error has occurred” - is this something wrong with SketchUp’s server or is there something I should be doing?

Any help much appreciated

Please try again, issue just got resolved

I have the same problem, it seems not to be solved at the moment

It deffinetly isn’t. I just did get a call like a minute ago from a client with that issue still occuring, maybe location have anything do to with that ? Client is from Poland. Told her to be patient as Trimble resolves issue on their end but let’s make sure here that Trimble actually is fixing it as it still stands for some people.

I’m located in the Netherlands. And a client of mine has the same issue. I don’t think its the location.

We sincerely apologise for the issue you are experiencing. We are facing some server issues and our dedicated team is working on resolving those as quickly and as efficiently as possible. We thank you for your patience while we work on fixing the issue.


There’s also this https://status.trimblecloud.com/ looks almost the same but underneath there’s different set of informations. Despite that it’s little hard to tell what is what.

well, the entitlement servers provide the right products to Trimble ID’s . Already entitled Trimble ID’s should not be affected, only new and changed ones in the AMP…

Hello everyone!

The issue seems to be resolved.
Please, let us know if you are still getting error messages.

We thank you for your patience while we worked on fixing this issue.

I’ve just downloaded and installed Sketchup 2021 (30 days free trial), as I am attending a course in Sketchup tonight.
I get the same message as above, and is not able to open the software…
How can I solve this problem?

Best regards,
Ingunn FS

I’m experiencing the same problem this morning. I’m located in New York State.

Hello! Same problem in Chile!

Same here in Texas. At least you’re not alone!

1 Like

Are all of you running Sketchup for Mac?

W10 here.

1 Like

PS I’ve got different error messages when I reboot the software.
The last message I just got, was :
“We are experiencing technical difficulties
The subscription server response is invalid”.

I opened SKU on a Mac and get the sames messages… but now is working on both devices… I guess “they” fixed the problem!

Now it works for me also - after many reboots + attempts to log in, and a removal + reinstall of the software.
Hope the issue gets solved for all of you.

Best regards

Still down for me in USA. Incident report from SU: