What does this mean

sketchup
advice
modeling

#1

I get this error when trying to do a follow me.
“The path you have chosen does not begin or end on the extrusion cross section.”

I am trying to make a 1/2 circle around the inside top of the form. I copied the path so I wouldn’t have to keep selecting it. But everything I have tried gives me the error.

left lens form.skp (169.6 KB)


#2

Is this what you were trying to do?

left lens form.skp (736.8 KB)

This is what I did: first I selected out the top surface and its bounding edges and made them a group. Then I deleted the surface between them. I copied and imported the half round into the group. I triple clicked on the inner continuous edge and excluded the half round. Then I used Follow Me. It didn’t quite resolve fully so I had to manually infill the last closing section.


#3

I just selected the inner edges and ran follow-me. Almost the same outcome as @simoncbevans… Lots of edges that didn’t soften and smooth but it did close!
left lens form cleaned.skp (683,1 KB)

Edit: there were a few connected edges that couldn’t be softened an/or smoothed. I could delete them so probably weren’t connected to the faces…


#4

This is because you copied the path horizontally from where the half-circle profile is located. That doesn’t allow Follow Me to work properly.

Copying the edges to use as the path is a good idea but you should have moved the copy vertically. Then it would be usable as the path.

The edges mentioned in the previous post that were deleted are attached to the model. If you are planning to 3D print the result, you will need to clean that up.

Screenshot%20-%2012_20_2018%20%2C%206_52_00%20AM

Also, because of the missing faces behind the half circle, Follow Me will create faces that you don’t want. I’ve hidden the top face so the unwanted ones can be seen. Delete those faces and you should have a solid group or component.


#5

Thank you, thank you, thank you…
I still don’t understand the words of the error msg, but I copied the path directly below and it worked, sort of. Must be some issue with the model as I had to fix a couple places.
I swear when I used follow me before, my path was similarly located and it worked fine. But that is memory for ya.

I think one of the major issues was because of the way I constructed this. There were a lot of orphaned pieces VERY close and almost impossible to see.
But it is working. Thanks again.


#6

I’d say your memory is failing you regarding this. :slight_smile:


#7

hey, what do you expect at 76