Can anyone tell me why this happens in FollowMe, and how to fix it?

I just want the circle to follow the path. (See video.)
It started out right, but became something else, and I can get it to go right. What am I doing wrong?

Looks to me as if your cursor is getting off of the path and onto the edge of the cylinder. Try selecting the path first, then get the FOllow Me tool, and then click on the face.

In a case like this it would be better to draw the path to include the centerlines of the straight sections and place the circle at one end. Then do as I described above.

I have a keyboard shortcut for Follow Me.
FM

1 Like

That’s pretty much how I started out, except I drew out the straight section first, then tried to add the 90°, with the circle at the far end of the curve. I got part way there before it went off in a different direction. I solved it though, by pulling the curve from the straight section end, not from the circle end. Thanks for the tip.

A thing to add regarding Follow Me is that the first segment of the path needs to be perpendicular to the profile and the extrusion will end perpendicular to the last segment in the path. If you have just drawn an arc for the path, the first segment won’t be perpendicular to the end of the cylinder and neither will the last segment be perpendicular to the other cylinder.

1 Like

I’m not sure I get that. When I draw an arc off of a straight cylinder, wouldn’t the first segment be perpendicular to the end face of the cylinder?

Nope. At least not if you are drawing a quarter circle. Here I’ve got the cylinders set up something like yours with a 90° arc between. I’ve put centers of the cylinders on the axes. You can see that the end segments are not on the axis lines.

The result of Follow Me looks like this:

Follow Me projects the profile face to perpendicular to the first segment of the path before extruding the geometry.

Simplifying to just a circle and an arc.

4 in. dia. circle perpendicular to the green axis.

After Follw Me, you can see that the ends are perpendicular to the ends of the arc.

And due to the projection, the ends are no longer circles but ellipses.

Ah, but this is how I’ve been drawing my 90°s: I start with a full 180° and chop it off in the middle, to get the perpendicular segment.

That’s different. Starting with a full circle you can split it at the midpoints of segments that are 90° apart and that works. I use that for some things although for something like you appear to be modeling it seems like more work than extruding the entire thing in one go.

Thanks for your help Dave. And its good to know about the FollowMe perpendicular thing!

1 Like

Hey Dave-

I hate to bother you again, but there’s still something I’m missing about Follow Me, and I hope you can help.

So the idea here is to make a wire clip. I’ve drawn out the path with line segments and arcs. It seems pretty clean. At the foot of it is the cross-section of the “wire” that I want to “flesh out” the clip with. Here it is from a couple of different angles:

Then:


I select the pathway, switch to the Follow Me tool, and click. I get the straight sections, but the turns don’t materialize. From our previous conversation, I get that the end segments of the 90°s need to be perpendicular, and I then assume that in my pathway, they’re not. But if you look at the way the ends of the tubes form from the Follow Me tool, they are cut at slight angles- which looks to me like the tool is making sure that the ends ARE perpendicular.
So why then does the tool not complete the run and fill in the turns? And more importantly, what do I need to do to get the turns included in the operation? Thanks again for your assistance.

Sketchup has problems forming very small faces, the bends in the corners are causing very small triangles that sketchup won’t make.

Scale up by 10, 100 or 1000 and try again.

1 Like

Thanks Box, that totally worked! And I know that about Sketchup, but I was just so frustrated with the issue that I completely forgot about the scale I was working at. Ugh!

@Box got here before me but it looks like he has you sorted. Depending on what you need out of the model, remeber there’s always “The Dave Method”.

That’s useful to know. I would have thought that the original component would also be affected by the scaling of the copy. Thanks again Dave.

It would be if you open the component for editing and scale the geometry within. In this case you are only scaling the component, not the geometry within. It’s a little weird but try it once. You’ll see if works quite well.

I checked it out before coming back with the comment. I’ve already used it a couple times since. Works great. Thanks.

1 Like