What can I do about "Messed up Model" error while saving?

I’m not sure what to do about getting this “Don’t Panic your model is messed up” Error.

I have one clean solid component (The large heart), and one clean solid group of 3d text that I used the Subtraction Solid Tool to engrave the larger component… and even though I run CleanUp3 and I run Solid Inspector2 on every component to make sure it’s clean and solid… I keep getting this error message when I try to save. My models are blown up 1000 times large and I run all of the clean up and solid inspector tools before and after I merge or subtract anything.

I’m not sure what to do from here because all of my models are intended to be 3d printable so I’m not sure if I can ignore this error.

Looking at the newly “engraved” text… it appears fine and the component says it’s solid when running inspector tools. But if I try to save the model, or fix it running clean up… it wants to close some of the numbers.

I would greatly appreciate any advice. I’ve attached the model since I don’t create commercial jewelry, only projects for friends or family.final double hearts project.skp (853.0 KB)

copy paste into a new file and see if you get the message when you save it…


Ok Thank you for the suggestion. That sounds like a good work around for glitches or corrupt files.

I tried the copy/paste into a new file and Sketchup simply auto-healed it without asking. (It closed some of the engravings). So it looks like Sketchup won’t ignore whatever it does not like about it.

I have a feeling that if I try a different font, I may not have the error. The letters above the numbers on my model were a different font and they have not error. I wonder what is creating the error since both components are clean solids before I use the Outer Shell tool.

I think I found what is wrong but still not sure the best fix. When I try to connect the missing segment that is created when Sketchup auto-fixes my model… It won’t let me connect both of the ends.

I wonder how I could force it to connect because if I erase all of the remaining lines of the “9”, It would be difficult to redraw and place the font correctly to match the rest of the numbers.

So both numbers have a small opening where I circled in Red here. So would the reason I can’t connect them be that they are not coplanar? If they are not coplanar, how can I connect them ?

Thank you for any ideas.

I found a solution. What kept happening is that where my two red circle are… when I push/pulled the numbers down… Sketchup did not like the very small flat edge that was created… so that when I would save the file… Sketchup would want to get rid of it.

The solution was pretty simple, I erased some of those straight lines and drew new lines that would eliminate the small flat lines that caused problems.

So in the end, I’m actually glad Sketchup does this, because those ultra small straight edges would be hard to 3d print.

So maybe Sketchup impressively fixes the model because of that issue.

Great that this conversation led to the solution :wink:

1 Like

Yeah, I was multi-tasking. I was posting questions and working on the problem at the same time so that I may save everyone’s time.

1 Like