Weld Extension will not load

I am running a 2017 SU version. I previously had the Weld Extension loaded but has since been disabled since it was Unsigned. I ran into a brick wall trying to get this signed so uninstalled the Weld Extension
and attempted to install the latest version. It installed but did not show up in the Extension Manager. According to a SketchUp error message to load the extension I am to go to the Extensions tab of the Preferences wind and check the box next to extension.
In 2017 SU there is no Extensions tab in the Preferences window. Also the Extension does not even show up in the Extensions Manager. Any advice on how to load this extension?
Thanks!

The extension doesn’t need to be signed to work in SketchUp. The message indicates that you need to relax the the loading policy in Extension Manager. Do what the message says and set the loading policy to allow unsigned extensions to load.

BTW, you can’t sign extensions made by others.

How do you do that? The message says to go to the Extensions tab in the Preferences window. There is no Extensions tab in the Preferences Window.

I found the Loading Policy in the Extension Warehouse Settings. It says the following:


Which one of these needs to changed?
Thanks.

It should be set to Unrestricted as your screen shot shows.

Reboot your computer and then restart SketchUp.

1 Like

I rebooted, the extension finally showed up in tee Extension manager but is disabled:

Is this no longer a valid extension?

Oh, I got it to load finally. The greyed out Disabled box kind of threw me. I was able to select it an enable it finally.

Your help is much appreciated!

I think the extension description is a bit off.

1 Like