Installed plugins not appearing within Sketchup Pro 2016 program

I just installed a bundled set of plugins (6 to be exact), but only one is available to use within Sketchup even though the others show up in the Library/Application Support/Sketchup 2016/Sketchup/Plugins folder. I’ve deleted and reinstalled the latest SUP2016, restarted SUP 2016 and restarted my computer, but the other 5 still do not show up. Any help is much appreciated.

SketchUp Help: Extensions Loading Policy

Did you read the part about how there is now a Extension Load Policy for SketchUp 2016 and higher ?
Window > Preferences > Extensions Policy
You’ll need to switch to “Approve” or “Unrestricted” mode to load unregistered (unidentified) extensions.

SketchUpdate Blogs on SketchUp 2016:

User Guide for the new Tray system:

Thanks and very strange. I did try switching the settings around. Actually, my default from the get-go was set on Approve Unidentified Extensions, which I did several times and they didn’t show up. I tried the Unrestricted route at one point when I was at my wits’ end with no solution. I figured what the heck, I trusted this plugin, quit the program, restarted and it still didn’t work. Of course, now that I go to the dentist and complain about my tooth it stops hurting and sure enough, I tried Unrestricted again, quit the program and there they are. I hope they stay… Thanks.

Have you enabled the extensions in phe Preferences>Extensions dialog?


Turns out I need to keep the policy as Unrestricted in order for all the plugins to work. Switching my policies to the other options doesn’t allow me to use them.

Have you installed fresh copies recently? For the new system introduced in SU 2016, authors had to obtain a signing code from Trimble before the extension will load under anything except Unrestricted. Old versions won’t have the signing. Also, not all authors have yet gotten their extensions signed.