Plugins not enabled by default in SketchUp 2016


#1

C:\ProgramData\SketchUp\SketchUp 2016\SketchUp\Plugins\

When we copy a plugin to the above directory, they still need to be enabled for each user by going to Windows > Preferences > Extensions and checking the plugin. In Sketchup 2015, once we copied to the plugins directory in C:\ProgramData, it would automatically be enabled for each user. Any ideas on how to fix this?


#2

Win: "Window > Preferences > Extensions Policy > Unrestricted"
OSX: “SketchUp > Preferences > Extensions > Policy > Unrestricted”

which is btw the default Extension Loading Policy for SketchUp 2016.


#3

As you said the default setting is “Unrestricted.” The extensions still need to be manually enabled.


#4

I do remember a post from @TIG which explains this unwanted but not changable behaviour.


#5

I believe this is a known issue that was inadvertently introduced along with the extension signing mechanisms in 2016. Hopefully it is on the short list for correction in a maintenance release…


#6

I believe so… .
.
.