WARNING: Mac OS X 10.10.5


#1

WARNING WARNING WARNING

Do not install this update. The version of BugSplat bundled with SketchUp fails the security checks in this update, causing SketchUp to fail to run! Specifically, the OS reports that the code signature is not valid.


#2

@slbaumgartner, is that all versions of SU?

john


#3

Haven’t checked all versions, but definitely 2015

@Marc @tt_su, somebody HELP! I’m dead in the water!

The specific problem is with code signatures on dylibs, which makes me suspect that SketchUp is violating some rule introduced by the 10.10.5 fix that prevents the recently disclosed dylib elevation of privileges vulnerability.

Dyld Error Message:

Library not loaded: @executable_path/…/Frameworks/BugSplat.framework/Versions/A/BugSplat
Referenced from: /Applications/SketchUp 2015/SketchUp.app/Contents/MacOS/SketchUp
Reason: no suitable image found. Did find:
/Applications/SketchUp 2015/SketchUp.app/Contents/MacOS/…/Frameworks/BugSplat.framework/Versions/A/BugSplat: code signature invalid for ‘/Applications/SketchUp 2015/SketchUp.app/Contents/MacOS/…/Frameworks/BugSplat.framework/Versions/A/BugSplat’

/Applications/SketchUp 2015/SketchUp.app/Contents/MacOS/../Frameworks/BugSplat.framework/Versions/A/BugSplat: code signature invalid for '/Applications/SketchUp 2015/SketchUp.app/Contents/MacOS/../Frameworks/BugSplat.framework/Versions/A/BugSplat'

#4

one of the seldom cases a reinstallation might be helpful?


#5

Tried that. No change :cry:


#6

can you rename of move the lib sothat SU may claim but launch?


#7

That just causes SketchUp to fail with a library not found error.


#8

try if disabling the Gatekeeper helps:

sudo spctl --master-disable

#9

Nope. Same error - but thanks for your ideas!


#10

as a last resort try replacing the code signature with an ad-hoc identity by:

sudo codesign -f -s - /Applications/SketchUp 2015/SketchUp.app/Contents/MacOS/../Frameworks/BugSplat.framework/Versions/A/BugSplat

#11

Well, that worked! Thanks!

So the open question is “what was wrong with the SketchUp code signing originally?”


#12

all frameworks used need to be codesigned with the correct provisioning profile not being invalid or expired:

Xcode Code Signing


#13

Thanks for the report, I’ll take a look.
-m


#14

Some further info: I just did a power-off shutdown and cold reboot, and the problem seems to have gone away. The update install just did a restart. I wonder if something was cached that didn’t get flushed until full power off?


#15

I haven’t been able to dupe this issue, and “codesign -vv --deep SketchUp.app” isn’t reporting any signature problems.

Is anyone else seeing this?

Thanks,
Marc


#16

I haven’t had any problems with SketchUp under 10.11. Hopefully Apple won’t put into 10.11 what they put into 10.10.5!


#17

Just for giggles, @slbaumgartner, what’s your sudo’ers file look like? :grinning:


#18

I installed 10.10.5 on my iMac last night without any SU issues or an additional Shutdown required by Steve…

john


#19

Sorry for slow response, I was offline for the weekend. sudoers file looks pretty standard/default: various env Defaults,
root and %admin ALL=(ALL) ALL permissions,
ALL ALL=NOPASSWD for airport.

nothing else

I’ve come to believe that something got hung up during the install of the upgrade, and that messed up the code sign checking. A full power-off shutdown then cold boot seems to have cured it.


#20

@slbaumgartner I updated OS X 10.10.5 as well yesterday. Got alarmed by your post which I received by mail from this forum this morning. So in a hurry I checked my SU’s on both my Mac’s. I use SU2015 pro, and all worked well on my iMac and MacBook…no error messages at all. So probably something went wrong with ur OS X updates I recon.

gr. Frank