Walls not drawing to size I input (I'm new to this)

Hi. I am learning to use the software by watching Sketchup School videos and trial & error. I have watched and understand how to draw a line and input the exact size I want it to be from field measurements. In most instances when I go back to measure the wall or insert a door, it has not drawn to the size I input. I’ve tried repeatedly in both Sketchup Pro and Layout and this happens. I’m drawing in plan view, using Architectural and inches. What am I missing? thanks in advanceLPC Floorplan_08252020.skp (72.8 KB)

I can think of various possibilities, but without looking over your shoulder or seeing a model with the problem, I can’t say which (if any) is correct. It would be helpful if you can upload a model with your post. Either drag and drop a file onto the message edit window in your browser or click the upload icon in its menu (Looks like a little block with an up arrow) to upload. Wait for the upload to finish before clicking the reply button.

Are you following the right process? Click at the starting position, move the cursor in the desired direction, click again near the desired end, then let go of the mouse and just type the correct length. Do not click in the measurements box, just type and SketchUp will understand.

Are you entering the dimension in the right format? In Architectural style, SketchUp expects feet and inches, but you have to use the single and double quote to indicate what you mean, for example 4’ 6". If you omit the units, inches will be assumed.

Have you checked that the edge is in the plane you expected? Orbit around and see whether it is sloped out of plane.

Do you have length snapping enabled in Model Info->Units? That can make a length come out different than you expected, especially if the start position wasn’t quite where you intended. Most of us work with that option turned off.

What are you doing to determine the size of something you drew, in other words, what do you mean by “measure”?

thank you for the prompt response! I’m not sure how to answer all of your questions, but here’s what I can:
I uploaded the file in the previous comment.
I am following the correct process for drawing a line to size. I turned off “length snapping enabled” and started a new file. This time it worked properly (but I did have to draw one line twice). I “measure” by right clicking and verifying the info, using the dimension tool (when I drew it in layout-which I have even more questions about, and also by drawing another line that size and comparing when it wasn’t working out.
I don’t understand the bit about the plane.
The new file which I will attach did not have a place to input scale. Previously I always selected 1/4". Maybe I opened a different template for plan view?
I need a fewLPC Floorplan_08262020.skp (69.8 KB) more hours in the day to practice! thanks for your help.

Are there still issues in this version? This is what I see when I add dimensions in SketchUp.

You may be confusing SketchUp with LayOut. SketchUp does not have a setting for scale. You draw at full size and zoom or orbit as necessary to see what you need to see.