Walk throughs

I wonder if anyone has tried this idea?

You can create walk throughs in SU by using a series of scenes and transitions, but it’s labour intensive work.

Those of us with great dexterity (aka a SpaceMouse) can do fly throughs on screen. By using a video capture, you could produce something quite quickly.

That is not so easy with walk throughs where you want the camera to stay at a constant height. You can of course “walk” in SU and set the eyeline. Is there a way to combine that with the fluidity of using a SM? In short, can you fix the camera/eye height but still move around using the SM?

If you have a SpaceMouse, would not turning OFF the Up/Down motion in settings lock the camera to a single height?

If so, then you could position the camera at your starting position, turn off the setting, start the screen capture, and walk around wherever you want - at least on a single level! Wouldn’t work with any level changes - split levels, multiple stories, etc. And would be a bit of a PITA if you normally keep the up/down control ON for your navigation while modeling.

Note that I’ve NOT tested this - it’s just an idea.

There was discussion awhile back about a viewing “mode” where one might navigate a model like a first person video game. Complete with keyboard and mouse control. In my opinion, something along these lines would do a great job for what you are describing.

Sounds like a great idea. I have just looked at the settings but I can’t see a way of doing it. That’s not to say there isn’t one.

There is the walk tool in SketchUp, but I’ve never had great results with it. It will climb stairs, but it also climbs over furniture and kitchen islands, etc.

You could mix and match the scenes method with the SM. You can do scene transitions manually by clicking scene tabs, then use that scene as a starting point for a SM move, then transition to another scene before the next SM leg of movement, and so on.

2 Likes

I tried to screen capture the setting, but failed - so I’m going to try to describe it!

Open 3dConnection App (not settings within SketchUp).
Choose Settings.
On window that pops up, make sure you’re on Sketchup Settings - not other app settings.
Click on “Advanced”
On the window that pops up, there are 6 motions that you can turn on/off. Turn OFF the Up/Down setting.

And I tried testing, but my settings aren’t staying as I’ve set them! I’ve likely got a driver problem I need to resolve first.

Things may look different on my Mac.

By the app, do you mean this:

If so, when I click on Properties, I see this:

Is that the screen you refer to?

Yes, that’s the Mac equivalent for what he described.

I tried Disabling the Mouse Up and Mouse Down but it didn’t seem to make any difference.

I only just got a SM Compact in December and mostly liking it so far. I’ve only really used object mode. Anyone manage to master the other modes: Camera Mode, Target Camera Mode and Helicopter mode? Took me a while just to remember how to get this menu - Left button on the device.

Screen Shot 2021-05-01 at 11.25.09 AM

I have tried all the modes and always come back to Object.

1 Like

Same experience as @TheOnlyAaron. I just can’t seem to get comfortable with the other modes, whereas to me Object Mode is quite natural - as if the SM is a substitute for the object in the model.

Normally there is s detention collision feature with the Walk Tool. It allows climbing over some objects, like stair steps but stops you if the height is above a certain threshold. In old SU help it was specified but I cannot find it now. I tested with a step of 600 mm (24 inches) and it stops me. This collision detector can bee disabled to allow you to pass through walls. Press and hold the Alt Key on PC or Cmd key on Mac. BTW it is erroneously written Alt key in the Status bar for Mac and in the Web help. In the Instructor Window it is correct (Cmd key for Mac).

1 Like