Vray rendering too slow


#1

I’m rendering a Sketchup model with Vray. When I try to render it takes a lot of time to finish. What should I do?


#2

How long does it take to render?
How’s your irradiance map settings?
Do you have lots of displacements or bumps?


Try changing image sampler type to Adaptive Subdivision and Number of passes on your Light Cache to 8 (by default), test & see if that helps.

Also check this manual to get more information about those settings: https://docs.chaosgroup.com/pages/viewpage.action?pageId=2556782
https://docs.chaosgroup.com/display/VRAY2SKETCHUP/Light+Cache


#3

There are too many things that can contribute to this.
Also, there is a difference between actual render time and component definition reading. Does it take a long time for VFB to show the image and go over box by box? or take a long time for VFB to show up?

Assuming that you aren’t really familiar with all the settings, before messing so much with global settings, I would focus on removing heavy components.
Glancing at the tree, it seems that it might have a lot of parts to it. And the furniture inside of the room can be very heavy for calculating component definitions.

But then I can be wrong as there are many variables.


#4

Thanks


#5

Should I make a proxy for each heavy component.


#6

I think that is what people generally advise to do.

With that said, I personally don’t like proxy that much as i always had some sort of issues in collaborative work settings. And the purpose of proxies are to free up the graphics in viewport, not to reduce the render time i think.

Before you move onto proxy settings, test out if that is the cause of the problem. Delete the tree and other heavy furnitures and render. See if it improves significantly.


#7

I put all heavy geometry in a layer a hide it, but still renders too slow.


#8

Delete and purge. Not hide.

This is just to test out. So, I would eliminate a possibility of the component contributing to the render time. (Although it is unlikely if you didn’t see the component in the viewport)

When it is taking a long time, what does it say on the bottom of the screen? Does it move on from “calculating component definitions”?

You need to answer what @filibis had asked. He did ask some essential questions.

As I have said previously, there are too many variables. Perhaps you can post on V-ray forum. You may get a bit more help there than here.

https://forums.chaosgroup.com/

I would like to ask to share the model, but I don’t have V-ray 2.0 version on me. Share your model there and people would be able to troubleshoot. :smiley:


#9

I use only two displacement maps. In the wood floor and in the water.
It takes abut a day to finish the light cache.


#10

Did you try my previous suggestions and check if those help?


Try disabling both displacements, render and see if it helps. Bump for wood should be enough instead of displacement.


#11

I would suspect that is the contributor here. You can troubleshoot by yourself by eliminating those suspects. Then find out what alternatives possible are out there:


#12

This topic was automatically closed after 91 days. New replies are no longer allowed.