Viewport Adjustment in Layout

I find viewport sizes incredibly difficult to manage. I would just like to be able to drag the boundaries of the viewport around a specific area and then be able to scale the whole thing up and down, like you can in InDesign. The problem with Layout is that, once you have (laboriously and slowly) adjusted the edges around the part of the scene you want to show to the proportions you want (which are rarely the same format as the saved scene), the following happens: You turn off the ‘keep scale on resizing’ tick, and the content of the image you carefully framed, jumps back to a different position inside the frame! I love everything else about Layout but this is the one issue that keeps me from being able to show what I want on the page. Can someone please help?

Viewport management can be tricky I know. Can you say why you are unchecking the keep scale on resize option? Once you have the view you want why uncheck? Just trying to understand your situation to be of help.

Your post is in the feature request category…but you also ask for help…
so a comment on the FR:
I can see a use for what would effectively be a cropping function of the LO viewport…that would then allow scaling while maintaining the “cropped” view.

As to the request for help
I would resize the LO viewport so that the portion of the “scene” you wish to isolate is to your liking (size/scale) and then tick maintain scale on resize…then reduce LO viewport boundary to “crop” out what you don’t want to see.

You could also…beforehand draw a box that represents the size of your LO sheet that you wish to dedicate to this scene view and use it either as a guide to get sizing correct and/or use it as a clipping mask instead of reducing boundary of LO viewport after ticking maintain scale on resize. It is much quicker/easier than it sounds.

Charlie

1 Like

If LO had a live API it would take a few days to create a scale tool that is consistent to that in SU and scales the viewport content uniformly.

Thanks everyone for your replies. The problem arises when I uncheck the ‘maintain on resize’ box in order to make the window either bigger or smaller after I have set the right proportions and focus by moving the sides. Charlie’s suggestion of the cropping mask sounds like the solution, I didn’t realise that was available. Thanks again!