Viewing the whole model, not just a scene


#1

Hello, a friend sent me a sketchup file to practice with. However, the file contains a scene and I would like to view the entire model. Is there a way to hide scenes so that the whole model is visible?


#2

Open the model in the scene your colleague provided. Click View Extents and save as a new scene.


#3

That would be “Zoom Extents”.

Depending on the model, you might also need to turn on some layers. Open the Layers window and tick any empty boxes in the Visibility column.


#4

Thanks both - the issues is that the scene shows a section cut view so when I zoom extents it still has part of the model hidden. I have clicked the “display section cut” and “display section plane” buttons to try and reveal either the plane or disable the section cut view, but nothing changes. Do scenes “lock” section cuts into the model?


#5

No. When you select the model, what color is the bounding box? Is Unlock available in the right click Context menu?

Are you sure there is more of the model to see? It could be that the author actually cut across the model and deleted the part you can’t see.


#6

The section cut may be contained within a group and hidden.
If you turn on hidden geometry you should be able to see the orange of the section plane. You can then open the relevant group for editing and remove it, or deactivate it.


#7

Then there is nothing to see with the current layers set and the current ‘Hidden Geometry’. Turn on both (=check on all layers and =show 'Hidden Geometry) to make all geometry available for displaying. Then try again with both toggling buttons (=display ‘Section Planes’ and =display ‘Section Cuts’). Both switches work troughout the entire model, even in locked groups and components.


#8

Actually, if the section plane has been hidden directly with right click Hide for example, The Toggle Section plane won’t show it.
IOt will only show by turning on Hidden geometry.


#9

Selecting to view hidden geometry does reveal some additional elements. Now that I can see the hidden layers as hashed out objects, is there a way to “restore” it to a normal element/component. I have selected unhide all but it still appears as hashed out object.

Im not familiar with selecting layers?


#10

@Box, I know. That is why I started with making everything available for displaying, including section planes, by saying:


#11

You cannot select a layer in the model itself, only in the ‘Layer’ window, to toggle its visibility on/off.

SketchUp’s native ‘Unhide All’ is context sensitive. You need to open a group or component to ‘Unhide All’ that was hidden inside that group/component. Do so by going through each (nested) group or component.
Or use a plugin that does this by digging in/through all levels of (nested) groups and components to unhide all automatically.


#12

FYI, I moved this to the main SketchUp category, as the thread is about basic use, with nothing about Dynamic Components.


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.