View model materials in match photo view

I have imported a photo to match. All I want to do is add a small item and see it in the context of the photo. I set the axes etc. and then just add just enough of a model to enable me to position my component, which is a metal handrail. I then delete everything except my handrail.

My handrail has material set to metal. If I move the view so the matched photo disappears, my handrail looks metal. However, when I click the scene button to return to the match photo view, the handrail is just outlines.

Altering foreground photo % has no effect as I haven’t projected any of my matched image onto my model. Altering background photo % removes the matched photo, which is not what I want either.

How can I just add a component to a photo scene?

Thanks very much for any help.


Use the slider and checkbox for Foreground photo in Styles>Edit>Modeling settings to adjust how much the photomatch photo covers your model. Leave the Background photo on. The Foreground photo is not about projected textures - those are just normal textured materials.

Moving the slider for foreground photo doesn’t make the material of my added component appear. It is still just shown as an outline. If I change the view, the material appears but I then don’t have the matched photo showing.



Disable the checkbox as suggested by Anssi…

That’s done it. Thanks. I hadn’t appreciated the difference between zero % opacity and the unchecked checkbox.

Your help is much appreciated.


1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.