Vertical Orientation of Textures


#1

I am applying a shingle texture in Sketchup pallet to a model. As you can see from screen save, one plane is textured properly with shingles running horizontal. However, at the hip, it does not change directions to continue to run horizontal. Can a texture specify which side is up and down?

Eli


#2

Right click on the face, select texture, and modify to suit.


#3

If you apply the material to the surface instead of the wrapper, you can right click on that face and choose Texture>Position. Right click again and choose Rotate>90°.


#4

I must say though, unless you have fixed that model you are pretty much wasting your time. I see from your screenshot you are still using layers other than layer0 as the active layer.

Test this, try deleting any layer. I’ll be very surprised if it works.

I’m not trying to give you a hard time or anything, just trying to point out that you are not understanding layers and how they work in SU. They are not the same as Cad.


#5

SU is really rather good at “guessing” where the baseline of textures should be, especially roofs; I would guess that the the dormer’s eaves/gutter line isn’t actually running true to the green axis and/or is off the blue plane. (Another fact that perhaps points to this is that the dormer is made up of two faces rather than one)

I also think that the holes you’ve cut into the walls for the windows are not quite on the same plane as the walls; the weird shadows indicate triangulation of that face - turn on “hidden lines” and you will see lots of lines radiating from the window corners - if you can delete them without the face vanishing I would be surprised. (If you can, brilliant: do so.)

The solutions above will fix the symptoms, but not the underlying cause.


#6

Thanks for input. The solution to the texture directing was right click the selected plane, Make Unique Texture. It figured what I wanted and changed the alignment.

There are some oddness in this drawing. Why the planes would be off causing the unusual highlights, I do not know. It may be related to the import of file from datacad.

This screen view is after specifying hidden geometry. What is the syntax for turning on hidden lines?

Box, I appreciate you taking the time to give me feedback. I am now drawing on 0 layer. However, the file names were created from the import. If I draw it in layer 0, is it ok to create a group or component and move that to another layer that I can turn off to make invisible?

Thanks for input. It really helps.
Eli


#7

You shouldn’t need to make the texture unique before rotating it. That just creates needless file bloat.

All geometry should be on Layer 0. Components/groups can be associated with other layers.