Problem with brick material going vertical instead of horizontal

Hi everyone, it’s me again (sorry). I may, or may not, have resolved my layers & outline issues and begun to move forward with siding my model. However, the crawl space brick and the siding appears to want to go vertical on the east and west sides of the model and I have no idea how to fix this. I tried looking through old forum posts and found one that said the following:

"Gully_FoyleSketchUp SageMay '15

When a face is bounded by an inclined edge, it tends to fold a texture around that corner on a bias, or skewed. Without seeing your model, it’s hard to pinpoint an exact cause, but that’s the general idea.

You can adjust the orientation (rotation) of a texture on an individual face using the Position Texture tool (right-click face > Texture > Position). You may duplicate the orientation of the texture on a particular face on another face by sampling the texture using the texture eyedropper (Alt-Bucket) and then immediately applying the sampled texture on the other face."

But when I tried to right-click face>Texture>Position I had no such option. Can anyone shed some light on the problem? As always, thank (1.4 MB)


I’ve downloaded your model and can see what you mean.

I’ve doubled clicked into that group, for the walls, and then selected the face with the vertical siding on. When I right click, it does give me the Texture>Position option. When I selected this, it let me rotate the texture 90 degrees, to make it vertical.

I then sampled this to apply to the other faces where the siding is vertical, changing it to horizontal.

I’m not sure why you can not access the Texture>Position option. Are you double clicking on the Group to access it?


Also, just as a general comment, I notice that your internal walls seem to be drawn onto the floor face and then push/pulled upwards, meaning they are ‘joined’ to the floor.

The way I generally work is to create the floor slab as a separate group/component. The walls are then drawn separately, in their own group/component. These are drawn to sit on the floor slab (group/component).

Hope that makes sense and helps.

Kind regards


Awe Crude. :sob: EVERYTIME I feel I’m getting the hang of this program I find out how clueless I really am! My Sketchup for Dummies is failing me. I think I need a version called Sketchup for Imbeciles. :blush:

Dear Michael Siggers. Thank you for your help. I, too, do not know why I am not getting Texture>Position option when I right-click. I’ve tried both ways of editing in the Walls group double clicking to enter into edit mode and going to the outliner panel and right clicking Walls and edit group. Either way I do not get that option. I do have an option that says Make Unique Texture and Make Photo Texture, but no Texture>Position.

As for the floors, I remember watching a tutorial that directed me to pull them up a bit. Maybe I just shouldn’t have? My floors are on their own layer ~ should I make them a group? Thanks for the help. Robin

P.S. HOW do you see that “the walls are drawn on the floor face.” How do I edit that?

Hey :grinning:

I wouldn’t worry about the walls at the moment and the way they are drawn. It’s only because when I orbited below the model, you can see inside the walls.

The way I would do it is;

  1. Draw a face as the floor and then group that together.
  2. Then draw another face on top and use this face to create the outline of your walls.
  3. Delete any faces that are not required for the walls.
  4. Then, when you push/pull them up, the walls will have solid bottoms.

In terms of the texture, I just double clicked into the wall group, then I clicked on an individual face to select it, and then right clicked. Basically, I selected the face before right clicking.


And don’t beat yourself up about it too. I think it’s one of those software packages where it just takes time to get the hang of it. Things will just click into place more and more, the more you use it.

1 Like

To get the Texture option you have to select JUST a face - none of it’s edges.

Then R Click, Texture, Rotate and pick the angle

There is something odd about the model. To get the texture options to appear I had to eyedropper pick up the texture, then paint bucket fill the face with the texture it already had. After that the options showed up ok.

John missed a couple of steps, they are:

Right-Click on a face. Doesn’t matter if it was already selected.
Choose Texture/Position
Ignore the frightening pins, and right-click again.
Choose Rotate/90

By the way, once you have fixed one wall you can use the eyedropper to pick up its fixed texture, and then paint bucket click on other faces that need fixing.

But wait, there’s more! If all of the walls need the same texture you can do a Select All while inside the walls group, and paint bucket click on any face, and all the faces will then have that texture.

Videos are better than words!!! :wink:

1 Like

The video showed most of what the pins are good for, but didn’t show the simple rotate option.

One nice thing that the pins can do is to counteract perspective. The opposite use of the distort you showed. Suppose you want to put a photo of a building as a texture on a surface, but there are trees in the way, and so you have to take the picture from off to the side. You can use the pins in the way you did with the pegboard placement, to take the corners of the building and make them line up with the corners of the face in your model.

1 Like

:scream: Oh MY. I’m sure it sounds more difficult than it really is. I can’t wait until “I” can tell people where they are going wrong. LOL

As for this: That is exactly what I did…to no avail. I will try again tomorrow when my mind is fresh. Thanx a lot Mike. R~

I did that John: See screenshot below of what I get. I DO NOT get the option to select Texture when I right click.

Hey there @colin. Thanks for this! I will resume triage attempt in the morning. I’m beat. I hope this works. One step forward two steps back. :smile:

This video is very helpful @TheOnlyAaron. I don’t think I ever would have found it Googling “siding won’t apply horizontally.” LOL :wink:

I wonder if I’ll ever be advanced enough to even try to put a a photo texture on a building? That type of things seems like a waaaay in the distant future application. I haven’t even begun to tackle adding a second floor. She says groaning at the thought of that future task!

Hey @Colin…I think I have a program glitch and I don’t know what to do about it. I’ve been fiddling with trying to rotate the vertical walls and I [finally] got the option for Texture>Position after many attempts at right-clicking. I was able to rotate one wall. But when I went to do the next wall, I right-clicked and the option for Texture was not there. So I tried to use the eye dropper to sample the wall I corrected and fill it onto another wall, but all that did was fill it in with the solid color gray. So that didn’t work. I’m getting very frustrated as I don’t know why I can’t get the Texture option to show up in the drop down menu. Maybe I need an update?

You only need to do the last thing I suggested, Select All, choose the successful texture in the Materials panel (it will be in the In Model set), then use the paint bucket and click on any of the selected faces. All of them should then look right.

1 Like

I don’t know how I did it, but somehow all exterior wall siding is now going in the same direction. Whew! That was tough. I didn’t understand what you meant, by

but mission accomplished.

Robin, signing off until the next problem arises. :blush:

P.S. Hopefully this will help the next newbie when they come across this problem!

In the Materials palette is a drop down menu. One entry is “In Model” on Windows, and “Colors in Model” on Mac. Selecting that will show just the textures that are being used in the model.

There is also the Window/Model Info menu to know about. In there, under Statistics, is Purge unused. Clicking that will remove any textures that are “in model”, but not really being used.

Awesome. That is good info to know! Thanx Colin.

Ref: The model you shared in this topic.

The problem is you’re applying the material to the Group.
Texture > Position is only a Context Menu item of a Face, not a Group or a Component.

When you paint a Group or Component from the outside, all the default faces (both front and back) will display the color applied to the Group. But, you’re not painting Faces by painting a Group from the outside, you’re painting the Group. The faces within the Group still retain their default material attributes. They merely display the Group material because they’re part of the Group

You need to repaint the Group with the Default Material.
Then, open the Group for editing and apply the material to Faces within the context of the Group.

As for the front porch…
It’s a Group painted with the default material.
But nested inside that Group is another Group, painted with the brick material.
The faces within the nested Group are all the default material.

Nesting a Group inside a Group in that fashion does nothing but add needless complexity.
Explode the topmost or ‘parent’ Group.
Repaint the remaining Group with the Default Material.
Then, open the Group for editing and apply the brick material to the Faces.

Keep the Entity Info dialog open as you’re modeling so you know what you’re working with.

1 Like