Vector Rendering produces X-Ray effect?

render
modeling

#1

Hi,

I’ve just updated from SU/LO 8 to 2015 and am having issues when I select Vector Rendering. In 8 when I chose vector rendering it produced a crisp image where the panels/ surfaces were not detailed, but still physically there, i.e. in drawing a wardrobe only the outer lines of the doors would be shown when viewed from the front. Now when I choose vector rendering the outside of the doors are shown and all of the panels and details on the inside/behind, basically giving an X-Ray style. I use my own custom style (nothing fancy) but this does not show back edges or have any x-ray properties. I would still like to use vector rendering for the crisp lines/ details it gives in my finished fabrication drawings however do not want an X-Ray/Wireframe style. Could someone please help?


#2

The problem is related to OpenGL support in your graphics card driver. Compared to version 8 the subsequent versions of SketchUp and LayOut use the graphics card more extensively, even to produce image and 2D exports.

You could try updating the graphics card driver, or, if that doesn’t help, turning off Hardware Acceleration in SketchUp (Window menu>Preferences>OpenGL) and restarting SketchUp and/or LayOut before exporting your drawings.

Anssi


#3

Thanks, I’ll take a look at my graphics card settings. Seems strange though that it will accurately render all the lines in my model in a wireframe instead of just the visible/outer ones due to it being overloaded? Seems like the result is many times more difficult than what I had originally asked it to do…


#4

Have ‘beefed up’ the settings allocated to sketchup by my graphics card, and turned of hardware acceleration and the vector settings now behave as expected. Thank you for your help.


#5

You should go to the Nvidia website and see if they have an update for your driver (if your card is of the type you list in your profile). Using SketchUp without Hardware Acceleration is slow if your models are not very simple.

Also check in the 3D settings in the Nvidia control panel that SketchUp is using the Nvidia card and not the Intel chip built into your laptop CPU (Automatic selection does not usually work here)

This screenshot is from my desktop, the Geforce driver might have a slightly different dialog. But it should show your Nvidia card instead of the Automatic option.

While you are there, check that Antialiasing and Anisotopic Filtering are set to “Application controlled” or equivalent.

Anssi