V-ray materials disappear! Help!

I’m working on a huge project with about 90 materials and I was working during a long time, adding new materials with the interactive render, and I notice my CPU usage was 95%, so I save the project and tried to make a final render. And when I tried to render nothing happens, so I close the project, wait for a little and reopen it. Then I tried to render again and it was no materials in the render then I also notice there were no materials on Vray material list too!!!

  • Since I can see the materials on SketchUp, can I add them to Vray material list?

  • If not, I have an autosave project with the latest materials used, can I export all of them at once to my recent project?

I’m using:
SketchUp Pro 2016 (version 16.1.1449 64bit)
V-Ray 3.40.02
Windows 7 64Bit

Can you show us a screen shot of your SketchUp model with Face Style set to Monochrome?

That looks like Hidden Line, not Monochrome.

How do I set to Monochrome? (Sorry for my ignorance)

Screenshot%20-%203_20_2019%20%2C%2011_11_29%20AM

That gonna gives me the same result before!

Do you think this has anything to do with the fact that the materials disappear from the V-ray material list?

I would expect to see shading on the faces in the model if you are showing it in Monochrome. Something like this:

What I’m wondering is if you have back faces exposed.

Check if you activated ‘‘Material Override’’ in vray settings. If it is activated, just deactivate it…

Can someone answer these questions, please?

Can you upload the SU model to file share like Dropbox and post link…or Private message if you prefer and I can take a closer look at it.

Do not get me wrong but I do not feel comfortable giving you this project, this is a job for a company in which I am doing my first internship.

At the same time there were too many materials in this project, because some models came from the 3D warehouse.
I was already thinking about cleaning some materials. So I’m going to apply the materials one by one, so the project stays clean.

Thanks everyone for the help!

No offense taken. There’s just only so much we can do looking a screenshots :wink:

If you can make a quick test model to reproduce the same problem, you could upload that to the forum.

The last version of VRAY I used imported all SU textures automatically.

I found a solution!

I go to SU Materials select “In the model”, and there they are! All of the materials!
Then I go to V-ray Asset editor -> Materials and nothing! No Materials!
So I go again to SU Materials, select one material with the “eyedropper” paint bucket tool, and I edited the color,
Then I go to V-ray Asset editor again, and there they are, all of the materials! I rendered and voilà!!!

But then I save the project, close it, open again, and… ■■■■!!! No materials on V-ray asset editor! Why?

1 Like

Is your VRAY a licensed copy?
Is it compatible with SketchUp pro 2016?

Edited

click the pencil and edit the post, highlight and delete any images…

john

Thank you so much for sharing the solution! I was struggling with the same thing and I couldn’t find an answer anywhere… it is temporary solution like you said, but at least I can render my model now!

1 Like