V-Ray Focal Length Not Matching Sketchup Viewport

V-Ray is not rendering the scene with the same focal length (I think) as that of the Sketchup viewport.

I attached a couple pictures to show what I mean. I think they explain the issue pretty well. I’m sure this is because there is some fundamental thing about V-Ray that I don’t understand.

I’m a tadpole of a novice with V-Ray. It intimidates the heck out of me. So the only way I can figure out how to learn it is to dive in. I tried courses and they help a lot but often they lose me with terminology I don’t yet understand.

It’s one of those “I don’t know what I don’t know” plus “I didn’t know there’d be calculus involved” times “what’s a UV map” divided by “I don’t think I have 10,000 hours to learn this, Malcom!”

Can you share your model for a close look?

Do your have ‘safe frame’ turned on in the Vray settings?

Have you let a render run out fully to see if the preview is messed up and it gets corrected?
To save time, you can manage your materials by turning on the materials override - but you’ll need to make sure that the glass material will still render as clear, then do a med quality render to see if things are working properly before you commit to a higher quality.

Vs

Also, at least once a week I will get deep into setting up a vray scene and running low quality render tests and in the rendering window I’ll get weird color casts, strange artefacts, etc. - often quitting SKP, getting a fresh cup of coffee and restarting will fix it.

Also note that you can control the focal length in SKP, but also the aspect ratio Vray Settings. Play with this part to make sure you are getting what you are seeing, linked to my comment above with ‘safe frame’.

For the counter being low I’d move the camera around a bit, make another test render and see if there is some glitch happening somewhere.

Hi Deborah,
Yes this was / is a problem when using the advanced camera in Sketchup, I experienced similar issue a few years ago - I think under Vray 3.6.
At the time vray didn’t support/implement the advanced camera tools fully and this exact field of view issue occurred, and once it occurred it created a field of view disparity in all my cameras.
There is a ruby command you can enter to reset the field of view system, Ill try and find my original post in the Chaos Group forums.

Not sure what version you are on and TBH I haven’t used the advanced camera tools since then so I don’t know whether it has been addressed or not.

Try either deleting or hiding the glass in the window to see if that changes anything in the V-ray render. I have had this issue several times now where the glass material is actually bending the light and distorting the view outside a window. My guess is that your window is a flat 2d plane instead of a 3d object with thickness and the refraction is bending the light from outside like a lens. Annoying, but pretty cool that V-ray is that realistic! I attached a photo showing this. With the window on the right, the top half has glass with a thickness of .01", while the bottom glass is a flat 2d plane. You can see the bottom half of the window bends the light and distorts what the Vray viewport is seeing, making the neighboring building seem closer than it really is. Hope this helps!

2 Likes