V-Ray rendering troubleshooting help!

Hello community!

My first time reaching out here. I am trying to render some Sketchup scenes in Vray, however I am not getting great results. I have done some research on lighting and how important it is for the overall results. Every scene I am trying to render either comes out very dark, overexposed, grainy or/and with very low level of detail. I have used Vray textures for the most part. I am using natural lighting as well as artificial one, tried adding Vray lights to see if that helps. I got light mix on but nothing seems to be helping. I spent hours trying to figure it out, at this point I would love input from someone who knows what they are doing, it’s definitely not me!!

File is saved here:

I would really appreciate help figuring this out, I am quite lost at this point:)

Show us what you are getting in your renders.

FWIW, it would be good to make sure you are using tags correctly. ALL edges and faces should be untagged. Only components and groups should get tags.
Screenshot - 9_12_2022 , 10_42_09 AM
It would also help to purge unused stuff from your file.
Screenshot - 9_12_2022 , 10_43_13 AM
That reduced file size by 80%.

There are some exposed back faces that could cause you trouble in rendering. Should be no exposed blue back faces.

Looks like you placed lights inside walls. Moving them into the room would help.

Thank you so much for taking the time to look into it. I have reversed that face, purged the model, fixed up some of the light sources. The rendering hasn’t gotten better at all. Actually its looking worse and worse. I am not sure it has anything to do with the model itself, maybe some vray settings ?

1 Like

It looks like you don’t have quite enough light in the space. I expect @eric-s or @mihai.s will be along soon to give you some useful tips about how to deal with this. They are much more expert at Vray than I am but with your screen shot at least there’s something to work with.

1 Like

Does your model have any windows or openings for sunlight to enter?

If so, you could try using the lightgen option to setup the sky and sun for interiors

I think your lights are placed somewhat randomly. To make sense about it all I first removed the lights and all V-Ray data Then I started by painting the visible luminaires with an emitting material after correcting face orientation. A start, perhaps?

There’s a lot to try to diagnose here. First of all…agreed with all of @DaveR 's comments re: purging, using groups and tags, and making sure there are no reversed faces.

Next, not sure why - but I’m getting a lot of errors. The model is ‘buggy’…perhaps it’s trying to reference material data from the OP’s hard drive. I’d recommend a thorough cleaning of the model. Check out Thom Thom’s CleanUp Extension.

I ended up copy the model geometry and pasting into new fresh clean file -which helped some.

Next, re: the original question about lighting…I deleted all the existing lights and reset V-Ray’s render settings to default so I can start from scratch. When dealing with lighting, I recommend using the ‘Material Override’ setting so that you’re looking at just light and nothing else.

For glass materials, since you want light to come through it, It helps to uncheck ‘can be overridden’ in the materials property settings.

Moving on…the room is naturally dark because the only windows are on the east and west sides…which means you need to adjust your shadow to reflect either earlier in the morning or late afternoon so the sun can ‘come into’ the room.

Here is default lighting with some light coming from the opening next to the dining room table.

I’m a bit lazy so when I want to brighten a view up, I add an ‘Exposure’ to the corrections panel in the VFB/Frame Buffer. Make sure to also bring the ‘Highlight burn’ down as well.

Next. Try working with Sphere lights first. To me, they are the most versatile and forgiving when just starting out. Here I’ve added one sphere light inside of the hanging fixture above the island. I added it INSIDE the light component so it showed up in all the others. That way I only need to edit one light and it updates them all.
Screen Shot 2022-09-12 at 3.31.03 PM

Lastly, you can also see what it looks like when you adjust the sun position to come in from the other side. I say this as you want to work with your natural or environmental light first as if that’s done well, you won’t need much more in terms of artificial lights.

From here, I would just add a few lights at a time, making sure that if they are inside of a lamp, that you uncheck ‘can be overridden’ for that lamps material so that you can see the light come through. Be patient. Good lighting is an art and I’m no expert…I just know enough that it takes a lot pr practice and in some case, experimentation to get the results that will look the best.

Hope this helps some.

1 Like

For me, resetting the settings froze SketchUp but the removing all V-ray data worked.