Utterly bamboozled by Dimensions in Layout Templates

Having created a model in millimetres, architectural, in Sketchup, I am attempting to pull it all into layout for adding dimensions. The template I would like to use is a ArchD size, I have changed it all to relevant metric and 0.001m accuracy as and where I should, yet the dimension tool still brings up the measurements as imperial!?! if I select an ‘A4’ or “A1” template, they’re fine, if I select an imperial template and change the units, it simply does not work.

I am utterly bamboozled by this. Any workaround besides having to create my own template from scratch the tedious (frankly, silly) way?


The units the LayOut dimension tool shows are independent of any unit settings in the file, You set them in the Dimension tray. Not at SketchUp now to post a screenshot. You can even mix dimensions in different units on the same sheet.

1 Like

It literally wasnt working - whatever I did, didn’t change the imperial measurement from popping up.

having now done a full reboot, PRAM Reset on my Mac it has decided to play along.

Sometimes I guess you just have to do a hard reset :slight_smile:

1 Like