Using sketchup 2020 pro and cannot see the dimensions in print preview or when printed

I am using sketchup pro non profit and cannot get it to print correctly. Text does not show up in print preview or when printed. I have updated the graphics driver and restarted the computer multiple times. Before the update, the preview and print was much worse than now. I checked the graphics and it is intel 620 that is OpenGL 4.2. I don’t know what else to do. Help please. I have been working on this several days now.

What printer? Are the printer drivers up to date?

This is what I see with Print Preview in SU2020.

Have you tried using LayOut? Dimensions and other text done in LayOut will look better anyway and you can set up multiple views of your model on a single page.

I will up the drivers and get back in a minute.

I updated the printer drivers and I can see the dimensions if I set the font to 26, the the printout looks like the font is about 10 or ll. That messes up my view while I am drawing. I am not happy. What else can I do.

How large is the model? You could set the text size to some fixed dimension. Or you could use LayOut which, as I wrote before, will give you better control over the appearance of the text and dimensions and will look better.

I will try layout.

It worked in layout. Thanks, I will see if it works on the other plans that I created.
I really appreciate you sticking with me and helping me out. I had tried layout earlier before updating and it did not work. But it worked now. So I may have done something wrong before or the update of the driver helped.

Might be worth going through the LayOut course materials at

What sort of plans are you making anyway?

I am a winner of the Patents for Humanity Award for my invention of a new method of drilling boreholes for the poorest people on earth. My tool is a reverse flow air lift drill that can save millions of lives. I am building a instruction manual for the building and use of the tool. See my web page at