Printing of Dimensions

I am using Sketchup Pro 2023 and I cannot print the numbers of dimensions. I get the lines (usually) but not the actual dimensions. I have a very fast (Intel i9) computer with top of the line graphics. The computer is less than a year old so I doubt that is the problem. I am running Windows 11 Home.

The dimensions show on screen but not when printed and not even in the preview page.

I believe I have attached the file for this project.

Can anyone help?

Peg’s Computer Table.skp (155.3 KB)

When I preview a scene I see the dimensions. I have no printer mapped to my computer so can’t print to check and the preview doesn’t look very pretty.

Since you are using SketchUp Pro, why don’t you use LayOut? Add your dimensions in LO and make as many pages as you need for your shop drawings. Then export a PDF and print that. You’ll get better results than printing directly from SketchUp.

Question: Is there a reason why yuor model is mostly below the ground plane?

I thank you for your help. I have never used Layout and don’t know how to transition my model to that program. Can you direct me to a tutorial or a simple means to transition?

To answer your question as to why most of my model is below the ground plane, I started with the thickener of the top. I know that sounds a bit silly but my usual starting point is the top when I build a table. In the shop, I start with legs and skirts and stretchers.

If you will provide a little direction as to how to move to Layout, I’ll give it a try.

Thanks for your help!

I would start with the tutorials at

That explains the location of the model.

I would start in SketchUp with the legs and after making sure they are in the right place, model everything else to fit.

I’ve revised your model to make it more efficient and fix some small dimensional errors. Right now I’m setting up a quick plan in LayOut which I’ll send to you in a PM when I get it ready. It won’t be the entire thing but hopefully it’ll give you some ideas.

Great. Thank you! I found how to open a scene in Layout using the File menu. However, the dimensions do not show in Layout either. What am I doing wrong?

Do the dimensioning in LayOut, not in SketchUp.

Here you go. Here’s the SketchUp model, LayOut file, and a PDF export. I didn’t do the whole thing but hopefully you can get some ideas. Print the PDF and see how the dimensions look from that.
Peg’s Computer Table redux.skp (65.5 KB)
Computer Table for Peg.layout (280.9 KB)
Computer Table for Peg.pdf (16.1 KB)

BTW, your forum profile is quite out of date. Please update that. And you should update to SketchUp 2024 now.

Thank you for introducing me to Layout. I have figured out how to do as you suggested, and it works fine. Next time, I’ll go down this route to start with. It certainly makes better shop drawings.

Now, I need to learn to use LO as a regular tool.

Thanks for you help again.


1 Like

Good deal Tom.

Go through the tutorials at the link I provided and practice. It’ll come fairly easily.

FWIW, here’s the first sheet of a plan I did with SketchUp and LayOut. This one prints on Arch E paper (48 x 36 inches) which allows for full-sized patterns for the curvy bits.
Herreshoff Drawing Table Plan
I made this for a retired naval architect who wanted to build his own copy of L.F. Herreshoff’s drafting table.

1 Like