Using Intersect Tool


#1

#6 Wood Screw - Insert.skp (1.5 MB)
The included model has three views of the same #6 Screw Insert component. The first two were created within the model. Note that the intersect tool appears to work correctly. The added face intersects and creates to circle opening to the insert. When the #6 Screw Component is copied to another model, added the face and using the intersect tool only works randomly. Also, when the #6 Screw Insert is copied back into the model, adding the face and using the intersect tool does not work.
I can upload the larger model if anyone is interested.
My basic question is what am I doing wrong. To the best of my knowledge all surface are on axis - parallel, perpendicular and co-planar. All suggestion welcome


#2

I’m not entirely sure why you couldn’t get the face to appear properly when you copied the screw into another model and used the Intersect function. However, if you delete the face and then draw lines from the edge to the screw, you can get the face to reappear. Then delete the unneeded lines. Here’s your model again.

#6 Wood Screw - Insert~.skp (1.4 MB)


#3

Hi Joe,

The component that was copied hither and yon is indeed off kilter.
The error is miniscule but enough to cause issues.
The model is set to Fractional Inch length units, which are simply to coarse to detect small errors.
Learn to work in decimal units of 3-place precision or greater.
Push the precision to 6 places and use the Query Tool for investigative work.

Learn to assign appropriate properties to components when you create them.
In this case; Cut Opening and Glue to Any alignment properties would be appropriate.

The Create Component Dialog Box — SketchUp Help

Experiment with this revised copy of your component:
Cut Opening - Insert.skp (533.7 KB)

Notice when you bring a new instance from the components browser it automatically aligns to any face and cuts a hole when you click to place.

Some hole-cutting component rules:
• A copy of a hole-cutting component will again cut a hole when placed.
• Hole cutting magic disappears if you move a hole-cutting component from one face to another face.
• A hole-cutting component only cuts a face in the current modeling context.
• A hole-cutting component can only cut one face.


#4

Geo,
Thanks ever so much for your reply. Life and learn. I never bumped up against the “Cut Opening” property in components. Using your model, the insert aligns to the surface and cuts the hole. I tried to duplicate your insert by selecting properties glue to any and cut opening. The component does not align to the surface and does not cut a hole. What did I do incorrectly.
Second subject - can you guess why my copy/paste insert is off kilter. This seem to be reoccurring problem. How did you determine the insert was off kilter? Any help is greatly appreciated
Joe


#5

Geometry you wish to make into a hole-cutting component must be situated in a face with the desired hole already cut out.
Select the geometry, excluding the face it will cut, and make the component.

The idea here is…
The face to be cut must be present to facilitate setting the Glue to any and Cut opening properties.
Notice the gray area indicating the alignment/cutting plane and the unique X configuration of the blue component axis.

Here’s another example:
A simple window opening with some depth to the jamb cutting a hole in a single face.
Be aware a hole-cutting component can cut only one face.



#6

Again thanks for your response. I took several tries but I finally figures out how to use the axis property and then the component worked correctly. Now all I have to do is figure out how to make this all work in my original model.
Thanks again for your help - top notch
Joe