[URGENT] Exporting to .dae leaves an unkown shade!

Hello. I have an urgent question.

I am currently trying to export a sketchup model to cityengine through a .dae file, but failing to do so.
The model shows up, but some sides are shaded automatically. I have tried to open the .dae file in other programs, and they already looked shaded so I am guessing that this is happening when .dae is exported from sketchup.

The picture attached shows what the model looks like in cityengine (also looked the same when viewed in A360 Online viewer), though it shouldnt be this shaded.

I really need a solution right away, and I hope someone could help me >.<

Thanks a lot,
Mari

What options are you selecting when you export the DAE file?

Hi, thank you for your prompt reply!

I’ve fiddled with those options, and settled with
"triangulate all faces" “preserve component hierarchy” and “export texture maps” checked.

Just for information, I have also moved around the “lighting” tool inside sketch up but did not work ;(

Mari

What lighting tool? Perhaps you could upload the SketchUp file so we can see what you’ve got going on there.

Hello! Thanks for the reply.
By “lighting tool”, I meant the default shadow tool that comes up in Windows>Default Tray.

I will attach the sketchup file on here, and the .dae on the next comment.
Thank you for your helping!

Marikadomaesato.skp (2.8 MB)

The .dae file exported from the above sketchup file.
(it actually comes with a texture folder, but I couldnt upload it)

kadomaesato.dae (1.7 MB)

The Drawing Axes have been repositioned away from default position, aligned with SketchUp’s world axes.
Consequently the model was built some 121 kilometers from the Origin.
Reset the Drawing Axes and move the model to the Origin.
Then, turn on Hidden Geometry and clean up the stray geometry.


1 Like

Thanks! I tried but had no effect >.<
Made re-importing easier though!

Thanks all for the help. I figured out why this was all happening, and it was a setting in cityengine, not sketchup.
Just so no one else would suffer with the same problem, the solution was to change a setting in cityengine.

  1. Select the model
  2. On the right panel “Inspector”, you should see a list of attributes you can change.
  3. Change the “normals” attribute to anything other than the default; soft, hard or auto.
    DONE.

–> http://cehelp.esri.com/help/index.jsp?topic=/com.procedural.cityengine.help/html/manual/sm/workingWithStaticModels.html

Thank you again to you all for your time,
regards, Mari

2 Likes