Uploading file to Trimble Connect "failed to upload"

I’m not real familiar with Trimble Connect. I’m trying to upload a file and it keeps failing to upload. I’ve tried it from the desktop SU Pro 2023 app (on Apple Silicon) and through both Apple Safari and Brave web browsers. Nothing works.

I’ve read through a thread from 2021 and it seemed that Trimble, at that time, was working to get 2021 to work with TC. The suggestion was to back save to v. 2020. I tried that to no avail either.

Any ideas?

Thanks in advance.

I don’t know if it has something to do with Apple or your computer. I just tested publishing a model to Trimble Connect and had no problems at all. That’s on my PC with Win 10, though.

Do you have Edge or Chrome to try, too?
Can you open SketchUp for Web?
( go to myaccount.trimble.com Products > View included apps > launch SketchUp for Web )

It could be, Dave. I simply don’t know if that’s a problem for anyone else.

Hi, Mike, yes, I am able to open SU web. I use that a fair amount. Usually just for importing dwg files then downloading as SU files. For some reason, when I was using Pro 2020, trying to import dwg’s on the desktop always resulted in SU crashing. Probably an extension conflict.

No, I have not tried Edge or Chrome. I had thought, though, that Brave was based on the Chrome engine. I could be wrong. I’ll try downloading Chrome and see what happens.


I tried Chrome, Mike, no go there, either.

I tested from SketchUp 2023 on my Intel and M1 Macs. File/Trimble Connect/Publish As… worked on both machines.

So, Trimble Connect seems ok with 2023 models, and publishing from either kind of Mac works. Could you try being on a different network, even your phone as a hotspot, see if that makes a difference?

Assuming you know your password and all, try to clear the cookies and then go to connect.trimble.com start a new project.

Show a screenshot in this stage.
Than, hit the button on the right ‘Create 3D model’

Draw a cube and hit save.
Does that model show up when opening in the 3D browser?

Colin, I tried using my phone hotspot. still no ability to upload anything

I did this, Mike. I assume by “opening in 3D browser” you mean Sketchup Web. Yes, all of this resulted in a model created in Triple Connect that did show up in my Sketchup for Web app.

Interestingly, at one point in the process, not sure just where, a dialog box came up that seemed to allow for choosing my Trimble account. All that was available was Sketchup web free. My Pro subscription did not show up as an option. Yet, the cube created did show up in my paid account.

I have no idea what to make of any of that.

In the Settings > Project details, you can check on which account and owner the project is set to.
Make sure it is set to your subscription account.

Yes, it did pick my paid account. Not sure why it didn’t show up when creating the TC model of the cube.

I was able to make this work in the other direct:

I went to Sketchup Web

opened the file I was trying to upload “from my device”

I saved it to web

from there, I could go to Trimble Connect and import the file there. kind of a round about way, but I did get the model up onto TC

I’ll have to do more study to understand the difference between SU web and TC

In the desktop app, can you start a new file (or have one open,already) then open the saved cube file from TC. ([menu] File > Trimble Connect > open model)

yes, I am able to do that

Can you edit the cube and tha publish it back to cloud?
[menu] File > Trimble connect > Publish model

I was able to open the file of the cube via TC. Modified on desktop then it did publish back up via TC. I could open it in the Sketchup Web app and the changes were there. But, when I went to open it in TC, it took some time (for such a simple model) and then, while it shows as having been converted, in the TC 3D viewer pane, nothing is visible. I tried several “remedies” but the objects remain invisible in TC.

What is the best (quickest) resource to research the difference between SU Web and TC? And why one would want to use one over the other in any particular situation.

That’s odd. It shows two elements selected, though.
What happens if you click i (information)?
The main difference between the two is one being an editor and the other being just a viewer.
Can you share the cube?

this image is of the info window

how do I share from TC? it doesn’t seem to be stored locally on my HD

Using a relatively new iPad I uploaded a 111k model file successfully. But, my working 13.7 meg model refuses to be loaded to TC. Not sure I’m successfully threading this thread to figure the answer to my problem. Is there any simple and clear route to a successfully upload?

Can you share the model? I wonder if it’s something specific to the model or maybe your internet connection.