Upgrading to SU 2018

I paid my annual support dues and received my new license in email last night. It says the S/N and authorization code should allow me to upgrade to SU 2018, but there seems to be no way to do it.
When I try to upgrade from within SU it tells me I have the latest version.
And when I deactivated my current license and tried to input the new S/N and authorization code I was sent, it tells me that is for an older version, even though it begins with TA instead of SA. I’m presuming TA is for a later version than SA, but maybe I shouldn’t assume that?

Anyway, how do I upgrade?
I have a very large model: 360MB, and I am hoping the new version is more stable and better able to handle large models. Currently, the version I have has the following bugs:

  1. Cache fills up over time and the model starts to “lose” geometry, which reappears when SU is restarted and the model reloaded.
  2. Entity info disappears or refuses to change on different components when SU is used for a long time (hours) with a large model.
  3. The space bar does not select the pointer when SU first opens a model, large or small, but then eventually works for no reason I can discern.

I have an
iMac (Retina 5K, 27-inch, Late 2015)
4 GHz Intel Core i7
2 GB 1867 MHz DDR3
AMD Radeon R9 M395X 4 GB

When I bought the machine last May, I was told SU was not able to take advantage of the new hardware yet. I’m hoping that has changed with the new upgrade. What to do?

Go to www.sketchup.com/download/all and download latest version.

To get your new serial and authorization code, if it has not been communicated to you already.

Go to https://www.sketchup.com/license/renew

Insert your 2017 (or last pre 2018) licence, the system will check their database and report on your maintenance status together with a new serial for SUpro2018 if maintenance is current (which it should be from your feedback on when you bought / renewed / upgraded earlier in the year). Select option for information to be sent by e-mail, this include the authorization code which you will need.

Install SUpro2018, be sure do so “As Administrator”.

Insert serial and authorization code.

Done.

@NewThinking2 : the amount of RAM on your machine doesn’t look right, either it is a typo or you need to get some more.

Press tab a few times until the blue outline moves from the icons at the bottom left up to the pointer icon in the toolbar at the top left. Now pressing space will select the pointer selection tool. If you press tab too many times, press shift-tab to go back.

This has been a problem for years.

Oops, sorry, it should be 32GB, not 2GB. I’ll try the rest later. Thanks.

You can have multiple versions of SketchUp installed on your computer, each with their own serial number and autorisation key.

Well, not quite “Done” yet.
I installed SU 2018, set my template and opened it, but none of my extensions are there.
So, I went to the extension warehouse, again, downloaded the ones I had before, then supposedly installed them. But even though it says they are enabled in the extension manager, they are not showing up in the Extensions tab and so I can’t use them.
What to do?

Often you must quit and then restart SketchUp for newly installed extensions to “take”. This is because SketchUp only loads extension code while starting up.

Did you try restarting sketchup?

That helped…some. I now have 2 of my extensions, but not Chris Fulmer extensions, nor Solid Inspector. Supposedly these are installed and enabled too, but they do not show up as shortcuts like my old 2017 version or in the extensions warehouse.

Actually, I don’t see Solid Inspector in the list of installed extensions.
Eh, scratch that. I got it back by installing it…again. Weird.

Hello and I had the same issue, or pain in butt. Do you have SketchUcation Plug-in Tool or extensions from there. I have there extension tool and open it and from the gear icon > settings. You can do a bulk install, it took 2 minutes to get 28 extensions back on to 2018. It gives you the dialog box to accept and you click on consecutively.
I had to do each one, one at a time with-in S-UP extension manager and it is SLOW!!! I may also be missing something with the Warehouse installs.
Your choice, but I get most of them through SketchUcation and try avoiding the Extension Warehouse in S-UP. I have been lock-out, or it wont let you log-in. Not worth the hassle or waiting 1 minute to load each one, and if you have a few dozen, pack a sandwich…Peace…

Thanks.
I don’t have as many extensions as you but I did go through the laborious process of installing them one by one before I discovered the Sketchucation ext. manager. I see it is a good place to disable/enable plug-ins in the future. It keeps asking me for my PW, which I forgot, but it’s working anyway.

cool, and it is a free account and a great option when the Warehouse goes nuts. I have log-in to SketchUp from the little silhouette in the lower left corner. Then been denied or not allowed to log-in to the extension or 3D warehouse before. Then it takes forever crazy… it is a yearly event with the new update. Glad your got in solved …enjoy and …Peace…

several advanced extensions do require a runtime library of shared functions from the author to be installed (see plugin description):

• Extension Warehouse : ThomThom : TT_Lib²

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.