Updating problem with .NET Framework 4


#1

Hello,
My version is 14.0.49, and Sketchup warned me to download an update. When trying to install it, Sketchup tells me I need to have .NET framework 4 installed, and quits prematurely. But I already have .NET 4. I tried again from Microsoft site anyway, and I got "already installed prompt. Please help me with this.

By the way, my system is Windows 7 Pro Turkish.


#2

Do you get the same problem with the latest SketchUp 14.1 installer?


#3

Well, I don’t know if it is latest, but the file I downloaded from Sketchup site has 14.1.1282.0 version number in properties.


#4

My bad, I thought you where trying to install the 14.0 version. I have to defer to someone else on the team for this .NET issue.


#5

Thank you TT, looking forward to a solution :).


#6

Hi Emre,

I recommend running the .NET Framework repair utility:

http://www.microsoft.com/en-us/download/details.aspx?id=30135

Cheers!


#7

Hi Tommy,
Well that tool did not help. Then I uninstalled my .NET Framework 4.5.1 completely. Then installed .NET FW 4.0. Sketchup installer worked ok. But this time my other programs on the machine broke. Autocad does not work :(. So it means Sketchup installer is not compatible with newer versions of .NET

EDIT: I ran windows update on the machine, and everything is ok now. Version is back to 4.5.1. So it looks like a confirmed installer problem. Here are my specs again FYI:

  • Win 7 64 bit Turkish (emphasis on Turkish, this is why general program problems occur, there are special characters in alphabet which developers overlook.)
  • Sketchup Pro 2014
  • Core i7 3770K
  • 16 gb RAM
  • Geforce GTX 560 Ti

EDIT 2: Well I just realized this forum is very new. It is different but very practical when you get used to it. I am so happy to join you, and thank you for your help already.