Update to a better mouse (?)

Looking towards mouse, admitting it may be erroneous, but need to start somewhere.

To resolve: Strange snap behavior, EG; certain you snapped to 90 degree angle, only to find out moments, or worse, days/weeks later, that the root of your problem is the item got rotated 89.4 degrees, not 90. Ugh.
Also, trying to grab corner of an object, yet cursor seems to be snapping to a point a few thousandths away from what should be a perfectly obvious node to grab. (15 year veteran user of SU Pro, FWIW).

So - let me know if I’m barking up the wrong tree and another solution is in order, otherwise, suggestions for a higher-resolution mouse, in hopes of eradicating this buggy behavior. While I’ve always used off the shelf Logitech wireless, I suspect one or two I’ve picked up in recent year or so simply may have been too cheap / low resolution to be up to the task of CAD/3D drafting work.
Current models in question: M317 and an M325.

Important note: I’m one of those who does not get along well with a 3-d space mouse. After many hours of desperately trying to realize the full potential of it’s awesomeness, I just don’t get it, so it’s relegated to being a $100 paper weight.



Just out of curiosity, do you have the latest driver for your GTX installed? This would be relying on the Nvidia site info not Windoze.

Okay. My business machine is running a T1000, and I see a very recent update released. Downloading now, and maybe in an hour or so it will be complete (638 MB).
I’ll try this first.

I’m skeptical that your issues are due to the mouse resolution.

Regarding the rotation, do you have angle snapping enabled? Unlike length snapping, this is very rarely a source of problems and should be left on. And when an exact angle is needed you should start the rotation and then type the required value, not rely on a pick with the mouse.

Regarding imprecise inference picks, I wonder: how far is your model from the origin? The inference engine snaps to exact geometry, but when the model is far from the origin limitations of OpenGL cause it to miscalculate where the pick was located, which could cause an issue such as you describe.

If you did want to update to a better quality mouse, 3Dconnexion make mice too - so there shouldn’t be any conflict with your 3D space mouse as they use the same software.

But the problems you are describing don’t sound like they are mouse related.

If things are feeling off - maybe check your display scaling - SketchUp only official supports up to 150% scaling , if you have gone higher than this in windows it might cause weirdness

Also make sure that you have length snapping turned off.
Getting the right inference point is easier if you zoom in far enough. These errors tend to happen when different inferences are neat each other and a very small move of the mouse makes SketchUp snap to some “from point” inference instead of the intended endpoint.

To add to the above, use the arrow keys to lock inferencing.

Lots of great info/points here. In order:
1> Nvidia updated successfully to latest drivers
2> slbaumgartner: I too am skeptical that the mouse is the issue. I do have angle snapping enabled. Your second point: I am fairly far from origin. These issues seem to have crept in precisely as I’ve embarked on a massive (to me, as a cabinet maker) project. I am easily 40-50 ft from points of origin, so perhaps this is the most likely cause. Solution: break large homes into individual models for each room? A bit cumbersome when designer is dictating over one’s shoulder and wants to bounce around the structure freely. I do so for production, but by then, the damage is often already done.
3> Elmtec-Adam: Again, I agree that mouse is likely being blamed incorrectly. Display scaling currently set to 125%. Not sure if an adjustment up or down would make a difference, since I’m at an accepted level currently(?)
4> Anssi: happy to report, length snapping is always off.

5> RLGL: You are correct, and perhaps I need to tighten up my methodology in general to clean up. At literally thousands of hours in Sketchup, one is moving more on autopilot and proper attention can easily slip into bad habits.

Thank you all for the excellent review of settings, and appears I accidentally had them dialed in reasonably well.

I am curious; is there a way to reduce the level of sensitivity of this newly-evolved snapping feature? Many times, I find the crux of issue is related to the cursor snapping to a hidden point, such as opposite corner of a rectangle that is not visible. While this feature occasionally seems helpful, it most often causes me fits. While I realize it’s unlikely, it actually would be useful to be able to toggle the new and improved inference feature on/off (meaning, revert to older classic snap style, ignoring hidden points that the machine cannot possibly guess correctly that I would want to be grabbing at).

I’ll plod forward with the updated driver being only actionable remedy, but can say the last point still, naturally, grabs invisible points more often than it infers things correctly.
Still stumped on the rotation, other than to be more diligent in keying desired angle vs. relying on the snaps.


Well-known issue. Keep your model close to the origin.

Not to high jack the thread, but; What is “Far” from the origin? 40’-50’ doesn’t seem far, especially when talking about modeling a home.

That is not very far unless you have moved the drawing axes and the drawing origin is very far from the model origin. You can right-click on an axis and if “reset” is among the active options, you have moved the drawing axes. Particularly when parts or the whole model have been imported from CAD, we often see content located many, even thousands, of miles from the model origin.

No, though it has been discussed many times, SketchUp provides no means to turn off part or all of the inference engine nor to modify the size of its “capture window”. However, if you have a lot of things hidden and some of them are drawn close but not exactly at your target vertex, it is quite possible that the snap is pulled to a vertex in something that is hidden.

1 Like