Unwanted transparency

advice

#1


This is a rendition of a wood stove chimney cap that is made of 1/16" thick metal. It looks fine up close, but when I zoom out to see the entire model, the brackets become visible through the “walls”.
How do I prevent this from happening, short of “using” thicker metal?
chimney cap.skp (554.0 KB)
Maybe I’m posting this in the wrong category, but it’s the only one available that sort of fits…


#2

You can untick edges and profiles in view>edge styles


#3

That works, but it changes the entire model. Any way to apply this selectively?


#4

If you want to keep the edge style the same, you could assign the bracelet group to a layer called “far” and use scenes, turning that layer off when using a scene a certain distance away.
Ok, you wouldn’t see the bracelet through the top but depending how far you are zoomed out, you might not see it anyway.

Just and idea.


#5

You can select the brackets and soften smooth the edges.Select the brackets , open for editing, right click and select soften/smooth, slide the slider to your preference… You have to do each one becasue they arent components.


#6

They will be components, once I correct that slip-up. Just being my usual scatterbrained self.
Thanks, I’ll look into that.


#7

An easy way is to select each bracket in the outliner and edit with a right click and select soften smooth. I think you can select all four brackets in the outliner at the same time and soften/smooth


#8

chimney cap.skp (484.5 KB)


#9

Thanks for the mod, but how’d you manage to get that result without changing the bracket’s shape? When I soften/smooth them enough to get the desired effect, they become pillow-like, whereas the ones you sent me back keep their shape but don’t show through the outer ring when zooming out…


#10

All I did was convert all of the groups to components, made those brackets solid, and deleted some superfluous edges.in the brackets.


#11

he didn’t soften smooth. The edges are still showing through at a distance. Not sure but I think the soften/smooth function just hides the edges. It doesn’t really change the shape.


#12

"made those brackets solid"
Care to elaborate? I’ve been confronted with that for months, and Solid Inspectors (I or II) have proven to be a dead-end. I often wind up with groups or components that don’t show up in entity info as “solid”, seemingly without rhyme or reason. I’d sort of given up on the whole thing, but maybe you’ve got pointers?


#13

I don’t know what to tell you. I selected one of those bracket component and ran Solid Inspector 2. It told me what was wrong and gave options to fix them. I let it do that and moved on. There are some problems Solid Inspector can’t fix so you might have to fix them manually but at least it’ll highlight where they are.


#14

OK, thanks…
I guess I’ll have another go at the extension, or plug-in. Another stab at it might to the trick.
-A veteran noob…


#15

entity info says the brackets are solid. I noticed before there were some loose segments inside. I didn’t see any holes…but I don’t have inspector yet.


#16

OK, finally got the Solid Inspector 2 to work, thanks…
One last thing, if I may; How does one find/identify superfluous edges within, say, a solid component?


#17

I look for coplanar edges and delete them. They often occur due to the method some folks use to make 3D components. It’s usually possible to avoid them but when they occur, it’s best to erase them immediately.


#18

By what methods, or tools? I’ve tried Fredo’s edge inspector, which didn’t detect anything untoward.


#19

ThomThom’s CleanUp3 will get most of them but I still inspect the model for ones that might have been missed. Looking at the way faces are shaded can provide clues. Another simple way to check is to erase the suspected edge and see what happens.


#20

Okay, thanks.