Details not cutting through model face

I’m creating architectural details for a 3D model and I’m having some trouble with a vent cover. It’s a roughly 4’X4’ vent cover with a bunch of right-triangles on it with rounded corners. I’ve measured and created all the triangles, but when I try to delete the faces of the triangles so that there are perforated holes in the grill, only about 40% of them have individual faces that I can delete. When I click the rest, it defaults to the entire face. I’ve tried selecting the groups of triangles, right-clicking and selecting “Intersect with model”, but that has only worked on some. Any advice?

As an alternative you could create a material with a texture image of the grill. Is the physical structure of the grill essential to your model, or is it for visual only?

It’s for visual, but also for accuracy of the 3d model and how light would behave in the room. I just don’t understand how some of these triangles will cut the face, but others won’t. They’re all just copied/pasted so there’s no reason they should behave differently. I don’t want to have to draw this again.

1 Like

Intersect faces can be a little lackluster when it comes to large arrays of lines. I think it’s too many numbers to crunch in one go. I’ve often had to select the offending geometry and use the intersect option 2 or 3 times before it works.
Your best bet may be to make the grate in sections. Since it’s a repeating pattern, you can make one “block” of the triangles, then duplicate them in a grid, and then just delete the adjacent lines.

Since you mention 3D printing I presume you need the geometry. You could make you work easier if you would start with a rectangle, create the first hole, and copy it. Then extrude the face to 3D. This starts after I copied the first triangular hole to make the square of holes.


I tried this, but the same thing happens. The first few rows allow me to cut the faces, but the rest default to the entire face. I’m pulling my hair out trying to figure this out.

You tried what I show and it doesn’t work? That would imply that either the rectangle isn’t on plane or you aren’t copying the holes on plane.

I can send you the file if you want. Everything seems to be on plane.

It would help to see your file. Drag and drop the .skp file into your reply.

So as you suggested, I copied the holes and then copied/pasted them into proper orientation. When I drag a rectangle over it, only the top couple of rows allow me to cut through the face.

airreturn.skp (1.4 MB)

From the model you uploaded it doesn’t appear that you are doing what I showed starting with a flat rectangle, drawinging the pattern cell as a hole and copying it.

I did not use Copy and Paste. I used Move/Copy and created and array. I also didn’t make components. of the pattern cells. There’s no need for that at this stage.

I did create an array. I’ll try the flat rectangle strategy and see what happens.

It looks like you were just making up stuff as you went along

From your model file showing that the method I described works…

I’m not sure what “making stuff up as I went along” means, but I did your method and it seems to have worked. Thanks.

1 Like